mongoose — security advisory
Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.
- Products
- mongoose
- Affected versions
- 7.21+ds-1, 7.21+ds-1~bpo13+1, 7.21+ds-2, 7.22+ds-1~bpo13+1
- Fixed versions
- 7.22+ds-1
- CVEs
- CVE-2026-73255
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 22:33 UTC · Revision 1
Source evidence
Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.
osv:DEBIAN-CVE-2026-73255
mongoose
Fixed versions: 7.22+ds-1
Complete source record
{
"id": "2681c953a50850e72be5c9b9234ea1cfe54048baca774882257f374b6bff8668",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-73255",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-73255",
"summary": "Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.",
"evidence": "osv:DEBIAN-CVE-2026-73255",
"products": [
{
"name": {
"value": "mongoose",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "7.22+ds-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "7.21+ds-1",
"evidence": "/affected/0/versions"
},
{
"value": "7.21+ds-1~bpo13+1",
"evidence": "/affected/0/versions"
},
{
"value": "7.21+ds-2",
"evidence": "/affected/0/versions"
},
{
"value": "7.22+ds-1~bpo13+1",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2026-73255",
"aliases": [
"DEBIAN-CVE-2026-73255"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "7.22+ds-1"
}
]
}
],
"package": {
"name": "mongoose",
"purl": "pkg:deb/debian/mongoose?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"7.21+ds-1",
"7.21+ds-1~bpo13+1",
"7.21+ds-2",
"7.22+ds-1~bpo13+1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-73255.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:24.177830726Z",
"provider": "osv",
"upstream": [
"CVE-2026-73255"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-73255"
]
},
"related_cves": [
{
"value": "CVE-2026-73255",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 416732,
"published_at": "2026-08-20T18:16:46.313+00:00"
}