Skip to content
Heist/ feed
Back to feed
UnratedFix available

pcre3 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2006-7228

Integer overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 might allow context-dependent attackers to execute arbitrary code via a regular expression that involves large (1) min, (2) max, or (3) duplength values that cause an incorrect length calculation and trigger a buffer overflow, a different vulnerability than CVE-2006-7227. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.

Products
pcre3
Affected versions
Not specified
Fixed versions
6.2-1
CVEs
CVE-2006-7228
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 20:12 UTC · Revision 1

Source evidence

DEBIAN-CVE-2006-7228

core-osv · Original source

Published 14 Nov 2007, 21:46 UTC

Integer overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 might allow context-dependent attackers to execute arbitrary code via a regular expression that involves large (1) min, (2) max, or (3) duplength values that cause an incorrect length calculation and trigger a buffer overflow, a different vulnerability than CVE-2006-7227. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.

osv:DEBIAN-CVE-2006-7228

pcre3

Fixed versions: 6.2-1

Complete source record
{
  "id": "8acb9b3d82b85ec8c9fcc6dee57c87ec874b60ddab73ff04d39535289d8e260a",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2006-7228",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2006-7228",
    "summary": "Integer overflow in Perl-Compatible Regular Expression (PCRE) library before 6.7 might allow context-dependent attackers to execute arbitrary code via a regular expression that involves large (1) min, (2) max, or (3) duplength values that cause an incorrect length calculation and trigger a buffer overflow, a different vulnerability than CVE-2006-7227. NOTE: this issue was originally subsumed by CVE-2006-7224, but that CVE has been REJECTED and split.",
    "evidence": "osv:DEBIAN-CVE-2006-7228",
    "products": [
      {
        "name": {
          "value": "pcre3",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "6.2-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "unknown",
    "structured": {
      "id": "DEBIAN-CVE-2006-7228",
      "aliases": [
        "DEBIAN-CVE-2006-7228"
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "6.2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "pcre3",
            "purl": "pkg:deb/debian/pcre3?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-7228.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-22T23:47:24.294339534Z",
      "provider": "osv",
      "upstream": [
        "CVE-2006-7228"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2006-7228"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2006-7228",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 410436,
  "published_at": "2007-11-14T21:46:00+00:00"
}