Skip to content
Heist/ feed
Back to feed
HighFix available

ruby-rack — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2025-59830

Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default configuration (no explicit delimiter) could be exposed to increased CPU and memory consumption. This can be abused as a limited denial-of-service vector. This issue has been patched in version 2.2.18.

Products
ruby-rack
Affected versions
2.2.13-1~deb12u1, 2.2.6.4-1, 2.2.6.4-1+deb12u1, 2.2.7-1, 2.2.7-1.1
Fixed versions
2.2.20-0+deb12u1, 3.0.8-2
CVEs
CVE-2025-59830
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 23:24 UTC · Revision 1

Source evidence

DEBIAN-CVE-2025-59830

core-osv · Original source

Published 25 Sept 2025, 15:16 UTC

Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default configuration (no explicit delimiter) could be exposed to increased CPU and memory consumption. This can be abused as a limited denial-of-service vector. This issue has been patched in version 2.2.18.

osv:DEBIAN-CVE-2025-59830

ruby-rack

Fixed versions: 2.2.20-0+deb12u1

ruby-rack

Fixed versions: 3.0.8-2

ruby-rack

Fixed versions: 3.0.8-2

Complete source record
{
  "id": "0da84d306521f453cea21a6cdb53d7d20b7326aee0a715946d7eee7bb32d6405",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-59830",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2025-59830",
    "summary": "Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result, attackers could use ; separators to bypass the parameter count limit and submit more parameters than intended. Applications or middleware that directly invoke Rack::QueryParser with its default configuration (no explicit delimiter) could be exposed to increased CPU and memory consumption. This can be abused as a limited denial-of-service vector. This issue has been patched in version 2.2.18.",
    "evidence": "osv:DEBIAN-CVE-2025-59830",
    "products": [
      {
        "name": {
          "value": "ruby-rack",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "2.2.20-0+deb12u1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "2.2.13-1~deb12u1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.2.6.4-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.2.6.4-1+deb12u1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.2.7-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "2.2.7-1.1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "ruby-rack",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.0.8-2",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "ruby-rack",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.0.8-2",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2025-59830",
      "aliases": [
        "DEBIAN-CVE-2025-59830"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "2.2.20-0+deb12u1"
                }
              ]
            }
          ],
          "package": {
            "name": "ruby-rack",
            "purl": "pkg:deb/debian/ruby-rack?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "versions": [
            "2.2.13-1~deb12u1",
            "2.2.6.4-1",
            "2.2.6.4-1+deb12u1",
            "2.2.7-1",
            "2.2.7-1.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-59830.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.0.8-2"
                }
              ]
            }
          ],
          "package": {
            "name": "ruby-rack",
            "purl": "pkg:deb/debian/ruby-rack?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-59830.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.0.8-2"
                }
              ]
            }
          ],
          "package": {
            "name": "ruby-rack",
            "purl": "pkg:deb/debian/ruby-rack?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-59830.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T17:47:42.782770284Z",
      "provider": "osv",
      "upstream": [
        "CVE-2025-59830"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2025-59830"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2025-59830",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 418502,
  "published_at": "2025-09-25T15:16:13.78+00:00"
}