High
Security advisory
`cloudflared` versions prior to 2020.8.1 contain a local privilege escalation vulnerability on Windows systems. When run on a Windows system, `cloudflared` searches for configuration files which could be abused by a malicious entity to execute commands as a privileged user. Version 2020.8.1 fixes this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-24356
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:06 UTC · Revision 1
Source evidence
`cloudflared` versions prior to 2020.8.1 contain a local privilege escalation vulnerability on Windows systems. When run on a Windows system, `cloudflared` searches for configuration files which could be abused by a malicious entity to execute commands as a privileged user. Version 2020.8.1 fixes this issue.
osv:CVE-2020-24356
Complete source record
{
"id": "21db1bfdae045c54c548714052228451f96698c1e36a407280109f1911bae2d4",
"url": "https://osv.dev/vulnerability/CVE-2020-24356",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-24356",
"summary": "`cloudflared` versions prior to 2020.8.1 contain a local privilege escalation vulnerability on Windows systems. When run on a Windows system, `cloudflared` searches for configuration files which could be abused by a malicious entity to execute commands as a privileged user. Version 2020.8.1 fixes this issue.",
"evidence": "osv:CVE-2020-24356",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2020-24356",
"aliases": [
"CVE-2020-24356",
"GHSA-hgwp-4vp4-qmm2",
"GO-2022-0845"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/cloudflare/cloudflared",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "9323844ea773b1444460fa09295ab8c01a88d97e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:cloudflare:cloudflared:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2020.8.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2020.8.0",
"2020.7.4",
"2020.7.3",
"2020.7.2",
"2020.7.1",
"2020.7.0",
"2020.6.6",
"2020.6.5",
"2020.6.4",
"2020.6.3",
"2020.6.2",
"2020.6.1",
"2020.6.0",
"2020.5.1",
"2020.5.0",
"2020.4.0",
"2020.3.2",
"2020.3.1",
"2020.3.0",
"2020.2.1",
"2020.2.0",
"2019.12.0",
"2019.11.3",
"2019.11.2",
"2019.11.0",
"2019.10.4",
"2019.10.3",
"2019.10.2",
"2019.10.1",
"2019.10.0",
"2019.9.2",
"2019.9.1",
"2019.9.0",
"2019.8.4",
"2019.8.3",
"2019.8.1",
"2019.8.0",
"2019.7.0",
"2019.6.0",
"2019.5.0",
"2019.4.1",
"2019.4.0",
"2019.3.2",
"2019.3.1",
"2019.3.0",
"2019.2.1",
"2019.2.0",
"2019.1.0",
"2018.12.1",
"2018.12.0",
"2018.11.0",
"2018.10.5",
"2018.10.3",
"2018.10.2",
"2018.10.1",
"2018.10.0",
"2018.8.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-24356.json"
}
}
],
"modified": "2026-10-20T10:52:51.840899252Z",
"provider": "osv",
"references": [
"https://github.com/cloudflare/cloudflared/security/advisories/GHSA-hgwp-4vp4-qmm2"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-24356",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 383968,
"published_at": "2020-10-02T15:15:12.483+00:00"
}