strongswan — security advisory
strongSwan versions 5.9.2 through 5.9.5 are affected by authorization bypass through improper validation of certificate with host mismatch (CWE-297). When certificates are used to authenticate clients in TLS-based EAP methods, the IKE or EAP identity supplied by a client is not enforced to be contained in the client's certificate. So clients can authenticate with any trusted certificate and claim an arbitrary IKE/EAP identity as their own. This is problematic if the identity is used to make policy decisions. A fix was released in strongSwan version 5.9.6 in August 2022 (e4b4aabc4996fc61c37deab7858d07bc4d220136).
- Products
- strongswan
- Affected versions
- Not specified
- Fixed versions
- 5.9.6-1
- CVEs
- CVE-2022-4967
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:54 UTC · Revision 1
Source evidence
strongSwan versions 5.9.2 through 5.9.5 are affected by authorization bypass through improper validation of certificate with host mismatch (CWE-297). When certificates are used to authenticate clients in TLS-based EAP methods, the IKE or EAP identity supplied by a client is not enforced to be contained in the client's certificate. So clients can authenticate with any trusted certificate and claim an arbitrary IKE/EAP identity as their own. This is problematic if the identity is used to make policy decisions. A fix was released in strongSwan version 5.9.6 in August 2022 (e4b4aabc4996fc61c37deab7858d07bc4d220136).
osv:DEBIAN-CVE-2022-4967
strongswan
Fixed versions: 5.9.6-1
strongswan
Fixed versions: 5.9.6-1
strongswan
Fixed versions: 5.9.6-1
Complete source record
{
"id": "4ae016c5c4438a9234082212dbcfe378b0d89d624c3c42a30f7c9dfad1b635eb",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-4967",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-4967",
"summary": "strongSwan versions 5.9.2 through 5.9.5 are affected by authorization bypass through improper validation of certificate with host mismatch (CWE-297). When certificates are used to authenticate clients in TLS-based EAP methods, the IKE or EAP identity supplied by a client is not enforced to be contained in the client's certificate. So clients can authenticate with any trusted certificate and claim an arbitrary IKE/EAP identity as their own. This is problematic if the identity is used to make policy decisions. A fix was released in strongSwan version 5.9.6 in August 2022 (e4b4aabc4996fc61c37deab7858d07bc4d220136).",
"evidence": "osv:DEBIAN-CVE-2022-4967",
"products": [
{
"name": {
"value": "strongswan",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.6-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "strongswan",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.6-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "strongswan",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.9.6-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-4967",
"aliases": [
"DEBIAN-CVE-2022-4967"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.6-1"
}
]
}
],
"package": {
"name": "strongswan",
"purl": "pkg:deb/debian/strongswan?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-4967.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.6-1"
}
]
}
],
"package": {
"name": "strongswan",
"purl": "pkg:deb/debian/strongswan?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-4967.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.9.6-1"
}
]
}
],
"package": {
"name": "strongswan",
"purl": "pkg:deb/debian/strongswan?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-4967.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:36.565736720Z",
"provider": "osv",
"upstream": [
"CVE-2022-4967"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-4967"
]
},
"related_cves": [
{
"value": "CVE-2022-4967",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323759,
"published_at": "2024-05-14T11:57:00.55+00:00"
}