Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2019-6340

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2019-6340
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:02 UTC · Revision 1

Source evidence

CVE-2019-6340

core-osv · Original source

Published 21 Feb 2019, 21:29 UTC

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

osv:CVE-2019-6340
Complete source record
{
  "id": "7821ca922d8d42567acc8563bbfc89c02907ada930380298f74ee79451c1b089",
  "url": "https://osv.dev/vulnerability/CVE-2019-6340",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2019-6340",
    "summary": "Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)",
    "evidence": "osv:CVE-2019-6340",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2019-6340",
      "aliases": [
        "CVE-2019-6340",
        "DRUPAL-CORE-2019-003",
        "GHSA-3gx6-h57h-rm27"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/drupal/drupal",
              "type": "GIT",
              "events": [
                {
                  "introduced": "b73ab73d39dca97a12513e8a9e4f4da4b0676f5f"
                },
                {
                  "fixed": "41adc71929319a82ab6b894b410be74d6ad40ad5"
                },
                {
                  "introduced": "9b04d294324d9c76be4b596de4316cb8804e8223"
                },
                {
                  "fixed": "f4490205b801e91bc77d3b09dcba903e7b35a146"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "8.5.0"
                      },
                      {
                        "fixed": "8.5.11"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "8.6.0"
                      },
                      {
                        "fixed": "8.6.10"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "8.5.10",
            "8.6.9",
            "8.6.8",
            "8.5.9",
            "8.5.8",
            "8.6.5",
            "8.6.4",
            "8.6.3",
            "8.6.1",
            "8.5.7",
            "8.6.0",
            "8.5.5",
            "8.5.4",
            "8.5.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-6340.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:34.560549741Z",
      "provider": "osv",
      "references": [
        "https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-6340",
        "https://www.drupal.org/sa-core-2019-003",
        "https://www.synology.com/security/advisory/Synology_SA_19_09",
        "https://www.exploit-db.com/exploits/46452/",
        "https://www.exploit-db.com/exploits/46459/",
        "https://www.exploit-db.com/exploits/46510/"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2019-6340",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 433542,
  "published_at": "2019-02-21T21:29:00.343+00:00"
}