Security advisory
omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-15240
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:53 UTC · Revision 1
Source evidence
omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.
osv:CVE-2020-15240
Complete source record
{
"id": "48142766ffc6725069185ab91b4c8408fedc25d4b0a963859093cf200794d3f1",
"url": "https://osv.dev/vulnerability/CVE-2020-15240",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-15240",
"summary": "omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.",
"evidence": "osv:CVE-2020-15240",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2020-15240",
"aliases": [
"CVE-2020-15240",
"GHSA-58r4-h6v8-jcvm"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/auth0/omniauth-auth0",
"type": "GIT",
"events": [
{
"introduced": "c091def58305469b55365a29c12431b8cd07cd4a"
},
{
"fixed": "ce6824dd0ca306b5d0e7bf33fdae8404b0259da6"
},
{
"fixed": "fd3a14f4ccdfbc515d1121d6378ff88bf55a7a7a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:auth0:omniauth-auth0:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "2.3.0"
},
{
"fixed": "2.4.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "fd3a14f4ccdfbc515d1121d6378ff88bf55a7a7a"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v2.4.0",
"v2.3.1",
"v2.3.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-15240.json"
}
}
],
"modified": "2026-10-20T10:51:54.008553126Z",
"provider": "osv",
"references": [
"https://github.com/auth0/omniauth-auth0/security/advisories/GHSA-58r4-h6v8-jcvm",
"https://rubygems.org/gems/omniauth-auth0",
"https://github.com/auth0/omniauth-auth0/commit/fd3a14f4ccdfbc515d1121d6378ff88bf55a7a7a"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2020-15240",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 383102,
"published_at": "2020-10-21T18:15:12.813+00:00"
}