Critical
Security advisory
Apcupsd 0.3.91_5, as used in pfSense through 2.4.4-RELEASE-p3 and other products, has an Arbitrary Command Execution issue in apcupsd_status.php.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-12585
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:45 UTC · Revision 1
Source evidence
Apcupsd 0.3.91_5, as used in pfSense through 2.4.4-RELEASE-p3 and other products, has an Arbitrary Command Execution issue in apcupsd_status.php.
osv:CVE-2019-12585
Complete source record
{
"id": "836e60dd4e2994c0c61bc5d00c0de017411af868c1719f13148d6450dfb6bd77",
"url": "https://osv.dev/vulnerability/CVE-2019-12585",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-12585",
"summary": "Apcupsd 0.3.91_5, as used in pfSense through 2.4.4-RELEASE-p3 and other products, has an Arbitrary Command Execution issue in apcupsd_status.php.",
"evidence": "osv:CVE-2019-12585",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2019-12585",
"aliases": [
"CVE-2019-12585"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/pfsense/freebsd-ports",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "cce2c24e75bd0c986602bb7027d235c9dff7cde0"
},
{
"introduced": "cce2c24e75bd0c986602bb7027d235c9dff7cde0"
},
{
"last_affected": "3d2a117caf1fdca4b1c2495c5b0d20700cb0354c"
},
{
"fixed": "b492c0ea47aba8dde2f14183e71498ba207594e3"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:netgate:pfsense:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.4.4"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:netgate:pfsense:2.4.4:-:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.4-NA"
},
{
"last_affected": "2.4.4-NA"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:netgate:pfsense:2.4.4:p1:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.4-p1"
},
{
"last_affected": "2.4.4-p1"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:netgate:pfsense:2.4.4:p2:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.4-p2"
},
{
"last_affected": "2.4.4-p2"
}
],
"source": "CPE_STRING"
},
{
"cpe": "cpe:2.3:a:netgate:pfsense:2.4.4:p3:*:*:*:*:*:*",
"range": [
{
"introduced": "2.4.4-p3"
},
{
"last_affected": "2.4.4-p3"
}
],
"source": "CPE_STRING"
},
{
"range": [
{
"fixed": "b492c0ea47aba8dde2f14183e71498ba207594e3"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"2.4.4-NA",
"2.4.4-p1",
"2.4.4-p2",
"2.4.4-p3",
"devel_before_hashes_changed",
"END-OF-2015Q4"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-12585.json"
}
}
],
"modified": "2026-10-20T10:51:37.311757881Z",
"provider": "osv",
"references": [
"https://ctrsec.io/index.php/2019/05/28/cve-2019-12584-12585-command-injection-vulnerability-on-pfsense-2-4-4-release-p3/",
"https://redmine.pfsense.org/issues/9556",
"https://github.com/pfsense/FreeBSD-ports/commit/b492c0ea47aba8dde2f14183e71498ba207594e3"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:apcupsd:apcupsd:0.3.91_5:*:*:*:*:*:*:*"
],
"vendor_product": "apcupsd:apcupsd",
"extracted_events": [
{
"range": [
{
"introduced": "0.3.91_5"
},
{
"last_affected": "0.3.91_5"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2019-12585",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 382665,
"published_at": "2019-06-03T03:29:00.273+00:00"
}