Skip to content
Heist/ feed
Back to feed
Medium

SiteOrigin Widgets Bundle <= 1.61.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via SiteOrigin Blog Widget

Type: advisorySources: OSV

The SiteOrigin Widgets Bundle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's SiteOrigin Blog Widget in all versions up to, and including, 1.61.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-5090
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 15:56 UTC · Revision 1

Source evidence

SiteOrigin Widgets Bundle <= 1.61.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via SiteOrigin Blog Widget

core-osv · Original source

Published 11 Jun 2024, 02:01 UTC

The SiteOrigin Widgets Bundle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's SiteOrigin Blog Widget in all versions up to, and including, 1.61.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

osv:CVE-2024-5090
Complete source record
{
  "id": "68212ec1e7523bbeec5dfad6cc83f8933e4bf178492c2a08e5d2b5504c4b4211",
  "url": "https://osv.dev/vulnerability/CVE-2024-5090",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "SiteOrigin Widgets Bundle <= 1.61.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via SiteOrigin Blog Widget",
    "summary": "The SiteOrigin Widgets Bundle plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's SiteOrigin Blog Widget in all versions up to, and including, 1.61.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
    "evidence": "osv:CVE-2024-5090",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-5090",
      "aliases": [
        "CVE-2024-5090"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/siteorigin/so-widgets-bundle",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4e332affb4582e921e40d6bff57e9e69b48ae5c4"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:siteorigin:siteorigin_widgets_bundle:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.62.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.61.1",
            "1.61.0",
            "1.60.0",
            "1.49.0",
            "1.48.0",
            "1.47.1",
            "1.47.0",
            "1.46.7",
            "1.46.6",
            "1.46.5",
            "1.46.4",
            "1.46.3",
            "1.16.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-5090.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:36.868245938Z",
      "provider": "osv",
      "references": [
        "https://plugins.trac.wordpress.org/changeset/3098819/so-widgets-bundle",
        "https://www.wordfence.com/threat-intel/vulnerabilities/id/2878de45-0123-4e07-bfec-015b36b11d01?source=cve",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/5xxx/CVE-2024-5090.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-5090"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "Wordfence",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.61.1"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/5xxx/CVE-2024-5090.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-5090",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 504359,
  "published_at": "2024-06-11T02:01:54.264+00:00"
}