Roxy-WI Vulnerable to Authenticated Remote Code Execution via OS Command Injection in find-in-config Endpoint
Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to version 8.2.6.4, the /config/ < service > /find-in-config endpoint in Roxy-WI fails to sanitize the user-supplied words parameter before embedding it into a shell command string that is subsequently executed on a remote managed server via SSH. An authenticated attacker can inject arbitrary shell metacharacters to break out of the intended grep command context and execute arbitrary OS commands with sudo privileges on the target server, resulting in full Remote Code Execution (RCE). Version 8.2.6.4 patches the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-33208
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 17:01 UTC · Revision 1
Source evidence
Roxy-WI Vulnerable to Authenticated Remote Code Execution via OS Command Injection in find-in-config Endpoint
core-osv · Original sourcePublished 24 Apr 2026, 02:10 UTC
Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to version 8.2.6.4, the /config/ < service > /find-in-config endpoint in Roxy-WI fails to sanitize the user-supplied words parameter before embedding it into a shell command string that is subsequently executed on a remote managed server via SSH. An authenticated attacker can inject arbitrary shell metacharacters to break out of the intended grep command context and execute arbitrary OS commands with sudo privileges on the target server, resulting in full Remote Code Execution (RCE). Version 8.2.6.4 patches the issue.
osv:CVE-2026-33208
Complete source record
{
"id": "bbeb24d878a4c061b7368f1c2fc54287f82f1118ea1d83d88d6f6f7a68c61894",
"url": "https://osv.dev/vulnerability/CVE-2026-33208",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Roxy-WI Vulnerable to Authenticated Remote Code Execution via OS Command Injection in find-in-config Endpoint",
"summary": "Roxy-WI is a web interface for managing Haproxy, Nginx, Apache and Keepalived servers. Prior to version 8.2.6.4, the /config/ < service > /find-in-config endpoint in Roxy-WI fails to sanitize the user-supplied words parameter before embedding it into a shell command string that is subsequently executed on a remote managed server via SSH. An authenticated attacker can inject arbitrary shell metacharacters to break out of the intended grep command context and execute arbitrary OS commands with sudo privileges on the target server, resulting in full Remote Code Execution (RCE). Version 8.2.6.4 patches the issue.",
"evidence": "osv:CVE-2026-33208",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-33208",
"aliases": [
"CVE-2026-33208",
"GHSA-7m2h-gmvj-cjx2"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/roxy-wi/roxy-wi",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "d72ea494d0bf1ee220fe141625a4298600f624ad"
},
{
"fixed": "02f147d567a3cc8cf61a4b58ea4c2b7866a544de"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:roxy-wi:roxy-wi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "8.2.6.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "02f147d567a3cc8cf61a4b58ea4c2b7866a544de"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v8.2.6.3",
"v8.2.8.2",
"v8.2.8.1",
"v8.2.6",
"v8.2.5",
"v8.2.4",
"v8.2.3",
"v8.2.2",
"v8.2.1",
"v8.2.0",
"v8.1.8",
"v8.1.7",
"v8.1.6",
"v8.1.5",
"v8.1.4",
"v8.1.3",
"v8.1.2",
"v8.1.1",
"v8.1.0.1",
"v8.1",
"v8.0.2",
"v8.0.1",
"v8.0",
"v7.3.2.0",
"v7.3.1.0",
"v7.3.0.0",
"v7.2.6.0",
"v7.2.5.0",
"v7.2.4.0",
"v7.2.3.0",
"v7.2.2.0",
"v7.2.1.0",
"v7.2.0.0",
"v7.1.2.0",
"v7.1.1.0",
"v7.1.0.0",
"v7.0.4.0",
"v7.0.3.0",
"v7.0.2.0",
"v7.0.1.0",
"v7.0.0.0",
"v6.3.19.0",
"v6.3.18.0",
"v6.3.17.0",
"v6.3.16.0",
"v6.3.15.0",
"v6.3.14.0",
"v6.3.13.0",
"v6.3.12.0",
"v6.3.11.0",
"v6.3.10.0",
"v6.3.9.0",
"v6.3.8.0",
"v6.3.7.0",
"v6.3.6.0",
"v6.3.5.0",
"v6.3.4.0",
"v6.3.3.0",
"v6.3.2.0",
"v6.3.1.0",
"v6.3.0.0",
"v6.2.3.0",
"v6.2.2.0",
"v6.2.1.0",
"v6.2.0.0",
"v6.1.5.0",
"v6.1.4.0",
"v6.1.3.0",
"v6.1.2.0",
"v6.1.1.0",
"v6.1.0.0",
"v6.0.3.0",
"v6.0.2.0",
"v6.0.1.0",
"v6.0.0.0",
"v5.5.1.0",
"v5.5.0.0",
"v5.4.3.0",
"v5.4.2.0",
"v5.4.1.0",
"v5.4.0.0",
"v5.3.6.0",
"v.5.3.5.0",
"v5.3.4.0",
"v5.3.3.0",
"v5.3.2.0",
"v5.3.1.0",
"v5.3.0.0",
"v5.2.6.0",
"v5.2.5.0",
"v5.2.4.0",
"v5.2.3.0",
"v5.2.2.0",
"v5.2.1",
"v5.2.0",
"v5.1.4.0",
"v5.1.1.0",
"v4.4.1.0",
"3.4.5.1",
"3.4.5",
"3.4.4.7",
"3.4.4.6",
"v3.3",
"v3.2.13",
"v2.0.2",
"v1.10.2.1",
"v1.10.2",
"v1.10.1",
"v1.10",
"v1.9.1",
"v1.6",
"v1.4.1",
"v1.4",
"v1.3",
"v1.1",
"v1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-33208.json"
}
}
],
"modified": "2026-10-28T02:30:37.790307268Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/33xxx/CVE-2026-33208.json",
"https://github.com/roxy-wi/roxy-wi/security/advisories/GHSA-7m2h-gmvj-cjx2",
"https://nvd.nist.gov/vuln/detail/CVE-2026-33208",
"https://github.com/roxy-wi/roxy-wi/commit/02f147d567a3cc8cf61a4b58ea4c2b7866a544de"
],
"provider_metadata": {
"cwe_ids": [
"CWE-78"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/33xxx/CVE-2026-33208.json"
}
},
"related_cves": [
{
"value": "CVE-2026-33208",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 505091,
"published_at": "2026-04-24T02:10:13.834+00:00"
}