rubygems — security advisory
Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every "Dependency Confusion" issue in every product.
- Products
- rubygems
- Affected versions
- Not specified
- Fixed versions
- 3.3.5-1
- CVEs
- CVE-2020-36327
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 11:08 UTC · Revision 1
Source evidence
Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every "Dependency Confusion" issue in every product.
osv:DEBIAN-CVE-2020-36327
rubygems
Fixed versions: 3.3.5-1
rubygems
Fixed versions: 3.3.5-1
rubygems
Fixed versions: 3.3.5-1
Complete source record
{
"id": "1273330652c5e3537907949d2c1d907ec4cb6924ad2f23887381515ee0a480d6",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2020-36327",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2020-36327",
"summary": "Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every \"Dependency Confusion\" issue in every product.",
"evidence": "osv:DEBIAN-CVE-2020-36327",
"products": [
{
"name": {
"value": "rubygems",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.3.5-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "rubygems",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.3.5-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "rubygems",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.3.5-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2020-36327",
"aliases": [
"DEBIAN-CVE-2020-36327"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.5-1"
}
]
}
],
"package": {
"name": "rubygems",
"purl": "pkg:deb/debian/rubygems?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-36327.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.5-1"
}
]
}
],
"package": {
"name": "rubygems",
"purl": "pkg:deb/debian/rubygems?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-36327.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.5-1"
}
]
}
],
"package": {
"name": "rubygems",
"purl": "pkg:deb/debian/rubygems?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2020-36327.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-09T09:47:33.164036839Z",
"provider": "osv",
"upstream": [
"CVE-2020-36327"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2020-36327"
]
},
"related_cves": [
{
"value": "CVE-2020-36327",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 111636,
"published_at": "2021-04-29T03:15:08.71+00:00"
}