High
Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...
Type: advisorySources: OSV
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-58098
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 03:00 UTC · Revision 1
Source evidence
Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...
core-osv · Original sourcePublished 5 Dec 2025, 13:40 UTC
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
osv:CVE-2025-58098
Complete source record
{
"id": "9a5554b208fd7bc4bda0b3fa8d368bac5484c1d389b1a11ea0d1fe3582fe957e",
"url": "https://osv.dev/vulnerability/CVE-2025-58098",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...",
"summary": "Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd=\"...\" directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.",
"evidence": "osv:CVE-2025-58098",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-58098",
"aliases": [
"BIT-apache-2025-58098",
"CVE-2025-58098"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/httpd",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e4a77ef6051b3fe22eafacbcf54855b178a0bddd"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.4.66"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.4.66-rc1-candidate"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-58098.json"
}
}
],
"modified": "2026-10-28T02:30:49.066028279Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58098.json",
"https://httpd.apache.org/security/vulnerabilities_24.html",
"https://nvd.nist.gov/vuln/detail/CVE-2025-58098"
],
"provider_metadata": {
"cwe_ids": [
"CWE-201"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "2.4.66"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/58xxx/CVE-2025-58098.json"
}
},
"related_cves": [
{
"value": "CVE-2025-58098",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517577,
"published_at": "2025-12-05T13:40:39.772+00:00"
}