UnratedFix available
gnupg2 — security advisory
The do_uncompress function in g10/compress.c in GnuPG 1.x before 1.4.17 and 2.x before 2.0.24 allows context-dependent attackers to cause a denial of service (infinite loop) via malformed compressed packets, as demonstrated by an a3 01 5b ff byte sequence.
- Products
- gnupg2
- Affected versions
- Not specified
- Fixed versions
- 2.0.24-1
- CVEs
- CVE-2014-4617
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:36 UTC · Revision 1
Source evidence
The do_uncompress function in g10/compress.c in GnuPG 1.x before 1.4.17 and 2.x before 2.0.24 allows context-dependent attackers to cause a denial of service (infinite loop) via malformed compressed packets, as demonstrated by an a3 01 5b ff byte sequence.
osv:DEBIAN-CVE-2014-4617
gnupg2
Fixed versions: 2.0.24-1
gnupg2
Fixed versions: 2.0.24-1
gnupg2
Fixed versions: 2.0.24-1
Complete source record
{
"id": "4540e7400b7046dd3561c6cb53030804e4c0f6bbb953b62f7b7f17a82af77fe6",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-4617",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-4617",
"summary": "The do_uncompress function in g10/compress.c in GnuPG 1.x before 1.4.17 and 2.x before 2.0.24 allows context-dependent attackers to cause a denial of service (infinite loop) via malformed compressed packets, as demonstrated by an a3 01 5b ff byte sequence.",
"evidence": "osv:DEBIAN-CVE-2014-4617",
"products": [
{
"name": {
"value": "gnupg2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.24-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gnupg2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.24-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "gnupg2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.0.24-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-4617",
"aliases": [
"DEBIAN-CVE-2014-4617"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.24-1"
}
]
}
],
"package": {
"name": "gnupg2",
"purl": "pkg:deb/debian/gnupg2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4617.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.24-1"
}
]
}
],
"package": {
"name": "gnupg2",
"purl": "pkg:deb/debian/gnupg2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4617.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.24-1"
}
]
}
],
"package": {
"name": "gnupg2",
"purl": "pkg:deb/debian/gnupg2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-4617.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:23.739786831Z",
"provider": "osv",
"upstream": [
"CVE-2014-4617"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-4617"
]
},
"related_cves": [
{
"value": "CVE-2014-4617",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 413761,
"published_at": "2014-06-25T11:19:22.637+00:00"
}