Skip to content
Heist/ feed
Back to feed
UnratedFix available

Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-006

Type: patchSources: Drupal security

Drupal core releases updates to address a vulnerability in the Guzzle library that may affect sites using Guzzle for outgoing requests.

Products
Drupal core
Affected versions
>= 8.0.0 <9.2.16 || >= 9.3.0 <9.3.9
Fixed versions
Drupal 9.2.16, Drupal 9.3.9
CVEs
CVE-2022-24775
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 15:15 UTC · Revision 1

Source evidence

Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-006

official-drupal-security · Original source

Published 21 Mar 2022, 21:39 UTC

Drupal core releases updates to address a vulnerability in the Guzzle library that may affect sites using Guzzle for outgoing requests.

Guzzle has released a security update which may affect some Drupal sites.

Drupal core

Fixed versions: Drupal 9.3.9, Drupal 9.2.16

Complete source record
{
  "id": "210537b540bd682466d3dd9a5c67e714b08408a4882420c295cc2eff61e7f443",
  "url": "https://www.drupal.org/sa-core-2022-006",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Moderately critical - Third-party libraries - SA-CORE-2022-006",
    "summary": "Drupal core releases updates to address a vulnerability in the Guzzle library that may affect sites using Guzzle for outgoing requests.",
    "evidence": "Guzzle has released a security update which may affect some Drupal sites.",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "Drupal 9.3.9",
            "evidence": "If you are using Drupal 9.3, update to Drupal 9.3.9."
          },
          {
            "value": "Drupal 9.2.16",
            "evidence": "If you are using Drupal 9.2, update to Drupal 9.2.16."
          }
        ],
        "affected_versions": [
          {
            "value": ">= 8.0.0 <9.2.16 || >= 9.3.0 <9.3.9",
            "evidence": "Affected versions: >= 8.0.0 <9.2.16 || >= 9.3.0 <9.3.9"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2022-24775",
        "evidence": "CVE IDs: CVE-2022-24775"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-drupal-security",
  "document_id": 23502,
  "published_at": "2022-03-21T21:39:35+00:00"
}