Critical
Security advisory
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-44223
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:23 UTC · Revision 1
Source evidence
WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.
osv:CVE-2021-44223
Complete source record
{
"id": "d3081058a27c3e7283f54f476c3d1a5a091023c1dd7086442714fd77653e15ef",
"url": "https://osv.dev/vulnerability/CVE-2021-44223",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-44223",
"summary": "WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.",
"evidence": "osv:CVE-2021-44223",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2021-44223",
"aliases": [
"BIT-wordpress-2021-44223",
"BIT-wordpress-multisite-2021-44223",
"CVE-2021-44223"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "50caeb6e61ad0c49d2c7e1d6d5115047a011f590"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-44223.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "4b54a6c2c9a3be775cc6dda66ed207998b068c8f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.8"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-44223.json"
}
}
],
"modified": "2026-10-24T10:30:27.936652262Z",
"provider": "osv",
"references": [
"https://make.wordpress.org/core/2021/06/29/introducing-update-uri-plugin-header-in-wordpress-5-8/",
"https://vavkamil.cz/2021/11/25/wordpress-plugin-confusion-update-can-get-you-pwned/"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-44223",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 431941,
"published_at": "2021-11-25T15:15:09.8+00:00"
}