Medium
Security advisory
An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances. Thus the previous password would still be active when it should have been changed.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2016-8647
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 05:19 UTC · Revision 1
Source evidence
An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances. Thus the previous password would still be active when it should have been changed.
osv:CVE-2016-8647
Complete source record
{
"id": "1a8fc2a332bbf523eb460c76775c8374936ba4b6ff8a70bf7587ea557a58c31e",
"url": "https://osv.dev/vulnerability/CVE-2016-8647",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2016-8647",
"summary": "An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances. Thus the previous password would still be active when it should have been changed.",
"evidence": "osv:CVE-2016-8647",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2016-8647",
"aliases": [
"CVE-2016-8647",
"GHSA-x4cm-m36h-c6qj",
"PYSEC-2018-58"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ansible/ansible",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "53629100006d1d8eebe3447235f8b4bf048a3dc0"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.2.1.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.2.1.0-0.5.rc5",
"v2.2.1.0-0.4.rc4",
"v2.2.1.0-0.3.rc3",
"v2.2.1.0-0.2.rc2",
"v2.2.1.0-0.1.rc1",
"v2.2.0.0-1",
"v2.2.0.0-0.4.rc4",
"v2.2.0.0-0.3.rc3",
"v2.2.0.0-0.2.rc2",
"v2.2.0.0-0.1.rc1",
"v2.0.0-0.5.beta3",
"v2.0.0-0.4.beta2",
"v2.0.0-0.3.beta1",
"v2.0.0-0.2.alpha2",
"v2.0.0-0.1.alpha1",
"v1.6.0",
"v1.4.0",
"v1.2",
"v1.1",
"v1.0",
"0.7",
"0.3",
"0.0.1",
"0.01"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-8647.json"
}
}
],
"modified": "2026-10-24T10:30:27.153784480Z",
"provider": "osv",
"references": [
"https://access.redhat.com/errata/RHSA-2017:1685",
"https://github.com/ansible/ansible-modules-core/pull/5388",
"https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8647"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:redhat:virtualization:4.1:*:*:*:*:*:*:*"
],
"vendor_product": "redhat:virtualization",
"extracted_events": [
{
"range": [
{
"introduced": "4.1"
},
{
"last_affected": "4.1"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2016-8647",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 431767,
"published_at": "2018-07-26T14:29:00.267+00:00"
}