High
GLPI vulnerable to arbitrary files deletion by technician
Type: advisorySources: OSV
GLPI is a free asset and IT management software package. Starting in version 0.78 and prior to versions 10.0.25 and 11.0.7, a technician can delete arbitrary files from the filesystem as long as the webserver has write rights on them. Upgrade to 10.0.25 or 11.0.7 to receive a patch.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-42317
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 17:59 UTC · Revision 1
Source evidence
GLPI vulnerable to arbitrary files deletion by technician
core-osv · Original sourcePublished 3 Jun 2026, 15:16 UTC
GLPI is a free asset and IT management software package. Starting in version 0.78 and prior to versions 10.0.25 and 11.0.7, a technician can delete arbitrary files from the filesystem as long as the webserver has write rights on them. Upgrade to 10.0.25 or 11.0.7 to receive a patch.
osv:CVE-2026-42317
Complete source record
{
"id": "ad37c8a4cdd4ec5df79e20255d251c1cdf2ea49183918f2ef541d9ea5fa3eedc",
"url": "https://osv.dev/vulnerability/CVE-2026-42317",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "GLPI vulnerable to arbitrary files deletion by technician",
"summary": "GLPI is a free asset and IT management software package. Starting in version 0.78 and prior to versions 10.0.25 and 11.0.7, a technician can delete arbitrary files from the filesystem as long as the webserver has write rights on them. Upgrade to 10.0.25 or 11.0.7 to receive a patch.",
"evidence": "osv:CVE-2026-42317",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-42317",
"aliases": [
"CVE-2026-42317",
"GHSA-jf72-cvjh-px5w"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "b5cb4adb3c350521d85209d49e29e8619cdf8316"
},
{
"fixed": "0ea900cb51a37f313c733b2024bf62f6a295c271"
},
{
"introduced": "73ce3740bcb1f9c9c5b96be469748be5f051ba49"
},
{
"fixed": "d91722c60d7552ae96c79774793bf45d78eb9771"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "11.0.0"
},
{
"fixed": "11.0.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "0.78"
},
{
"fixed": "10.0.25"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
}
],
"versions": [
"11.0.6",
"11.0.5",
"11.0.4",
"11.0.3",
"11.0.2",
"11.0.1",
"11.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-42317.json"
}
}
],
"modified": "2026-10-28T02:30:31.252188126Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42317.json",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-jf72-cvjh-px5w",
"https://nvd.nist.gov/vuln/detail/CVE-2026-42317"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42317.json"
}
},
"related_cves": [
{
"value": "CVE-2026-42317",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 498112,
"published_at": "2026-06-03T15:16:02.25+00:00"
}