MyEMS Admin Backend svg.py on_post cross site scripting
A vulnerability was found in MyEMS up to 6.4.0. The affected element is the function on_post of the file myems-api/core/svg.py of the component Admin Backend. The manipulation of the argument new_values['data'] results in cross site scripting. The attack can be launched remotely. The exploit has been made public and could be used. Upgrading to version 6.5.0 is sufficient to fix this issue. The patch is identified as 4a97edfbd786c779d0322054833b21ddf54d5b06. It is suggested to upgrade the affected component. The issue report remains open even though there is an official fix for it.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-15321
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 02:12 UTC · Revision 1
Source evidence
MyEMS Admin Backend svg.py on_post cross site scripting
core-osv · Original sourcePublished 10 Jul 2026, 02:45 UTC
A vulnerability was found in MyEMS up to 6.4.0. The affected element is the function on_post of the file myems-api/core/svg.py of the component Admin Backend. The manipulation of the argument new_values['data'] results in cross site scripting. The attack can be launched remotely. The exploit has been made public and could be used. Upgrading to version 6.5.0 is sufficient to fix this issue. The patch is identified as 4a97edfbd786c779d0322054833b21ddf54d5b06. It is suggested to upgrade the affected component. The issue report remains open even though there is an official fix for it.
osv:CVE-2026-15321
Complete source record
{
"id": "d2e6936711b87025cc937973f304ab6e81a3f5bb0e99f7aec4813c7f150a59e7",
"url": "https://osv.dev/vulnerability/CVE-2026-15321",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "MyEMS Admin Backend svg.py on_post cross site scripting",
"summary": "A vulnerability was found in MyEMS up to 6.4.0. The affected element is the function on_post of the file myems-api/core/svg.py of the component Admin Backend. The manipulation of the argument new_values['data'] results in cross site scripting. The attack can be launched remotely. The exploit has been made public and could be used. Upgrading to version 6.5.0 is sufficient to fix this issue. The patch is identified as 4a97edfbd786c779d0322054833b21ddf54d5b06. It is suggested to upgrade the affected component. The issue report remains open even though there is an official fix for it.",
"evidence": "osv:CVE-2026-15321",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2026-15321",
"aliases": [
"CVE-2026-15321"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/myems/myems",
"type": "GIT",
"events": [
{
"introduced": "4c373bdc1337886c7f1c2e33fd94b680ea44cbf5"
},
{
"fixed": "4a97edfbd786c779d0322054833b21ddf54d5b06"
},
{
"fixed": "df3a2183d8fa47fb517214616570098fb0632ac8"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "6.1"
},
{
"last_affected": "6.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "6.2"
},
{
"last_affected": "6.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "6.3"
},
{
"last_affected": "6.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "6.4.0"
},
{
"last_affected": "6.4.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "4a97edfbd786c779d0322054833b21ddf54d5b06"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "df3a2183d8fa47fb517214616570098fb0632ac8"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v6.5.0"
}
]
}
}
],
"versions": [
"6.1",
"6.2",
"6.3",
"6.4.0",
"v6.4.0",
"v6.3.0",
"v6.2.0",
"v6.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-15321.json"
}
}
],
"modified": "2026-10-28T02:30:53.022200505Z",
"provider": "osv",
"references": [
"https://github.com/MyEMS/myems/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/15xxx/CVE-2026-15321.json",
"https://nvd.nist.gov/vuln/detail/CVE-2026-15321",
"https://vuldb.com/cve/CVE-2026-15321",
"https://vuldb.com/submit/853060",
"https://vuldb.com/vuln/377263",
"https://github.com/MyEMS/myems/issues/412",
"https://vuldb.com/vuln/377263/cti",
"https://github.com/MyEMS/myems/commit/4a97edfbd786c779d0322054833b21ddf54d5b06",
"https://github.com/MyEMS/myems/releases/tag/v6.5.0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79",
"CWE-94"
],
"cna_assigner": "VulDB",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "6.0"
},
{
"last_affected": "6.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/15xxx/CVE-2026-15321.json"
}
},
"related_cves": [
{
"value": "CVE-2026-15321",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521674,
"published_at": "2026-07-10T02:45:09.559+00:00"
}