deepdiff — security advisory
DeepDiff is a project focused on Deep Difference and search of any Python data. Versions 5.0.0 through 8.6.0 are vulnerable to class pollution via the Delta class constructor, and when combined with a gadget available in DeltaDiff, it can lead to Denial of Service and Remote Code Execution (via insecure Pickle deserialization) exploitation. The gadget available in DeepDiff allows `deepdiff.serialization.SAFE_TO_IMPORT` to be modified to allow dangerous classes such as posix.system, and then perform insecure Pickle deserialization via the Delta class. This potentially allows any Python code to be executed, given that the input to Delta is user-controlled. Depending on the application where DeepDiff is used, this can also lead to other vulnerabilities. This is fixed in version 8.6.1.
- Products
- deepdiff
- Affected versions
- 6.2.2-1, 6.7.1-1, 6.7.1-2, 8.1.1-1, 8.1.1-2, 8.1.1-3, 8.1.1-4, 8.6.1-1, 9.0.0-1, 9.0.0-2
- Fixed versions
- 8.1.1-4+deb13u1, 8.6.1-1
- CVEs
- CVE-2025-58367
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 01:19 UTC · Revision 1
Source evidence
DeepDiff is a project focused on Deep Difference and search of any Python data. Versions 5.0.0 through 8.6.0 are vulnerable to class pollution via the Delta class constructor, and when combined with a gadget available in DeltaDiff, it can lead to Denial of Service and Remote Code Execution (via insecure Pickle deserialization) exploitation. The gadget available in DeepDiff allows `deepdiff.serialization.SAFE_TO_IMPORT` to be modified to allow dangerous classes such as posix.system, and then perform insecure Pickle deserialization via the Delta class. This potentially allows any Python code to be executed, given that the input to Delta is user-controlled. Depending on the application where DeepDiff is used, this can also lead to other vulnerabilities. This is fixed in version 8.6.1.
osv:DEBIAN-CVE-2025-58367
deepdiff
Fixed versions: Not specified
deepdiff
Fixed versions: 8.1.1-4+deb13u1
deepdiff
Fixed versions: 8.6.1-1
Complete source record
{
"id": "a474a9351921ee631f3d630125eb409e33df533c9ad762281fce53160b5f64b3",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2025-58367",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2025-58367",
"summary": "DeepDiff is a project focused on Deep Difference and search of any Python data. Versions 5.0.0 through 8.6.0 are vulnerable to class pollution via the Delta class constructor, and when combined with a gadget available in DeltaDiff, it can lead to Denial of Service and Remote Code Execution (via insecure Pickle deserialization) exploitation. The gadget available in DeepDiff allows `deepdiff.serialization.SAFE_TO_IMPORT` to be modified to allow dangerous classes such as posix.system, and then perform insecure Pickle deserialization via the Delta class. This potentially allows any Python code to be executed, given that the input to Delta is user-controlled. Depending on the application where DeepDiff is used, this can also lead to other vulnerabilities. This is fixed in version 8.6.1.",
"evidence": "osv:DEBIAN-CVE-2025-58367",
"products": [
{
"name": {
"value": "deepdiff",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "6.2.2-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.7.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "6.7.1-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.1.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "8.1.1-2",
"evidence": "/affected/0/versions"
},
{
"value": "8.1.1-3",
"evidence": "/affected/0/versions"
},
{
"value": "8.1.1-4",
"evidence": "/affected/0/versions"
},
{
"value": "8.6.1-1",
"evidence": "/affected/0/versions"
},
{
"value": "9.0.0-1",
"evidence": "/affected/0/versions"
},
{
"value": "9.0.0-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "deepdiff",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.1.1-4+deb13u1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "8.1.1-4",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "deepdiff",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.6.1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "8.1.1-4",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "critical",
"structured": {
"id": "DEBIAN-CVE-2025-58367",
"aliases": [
"DEBIAN-CVE-2025-58367"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "deepdiff",
"purl": "pkg:deb/debian/deepdiff?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"6.2.2-1",
"6.7.1-1",
"6.7.1-2",
"8.1.1-1",
"8.1.1-2",
"8.1.1-3",
"8.1.1-4",
"8.6.1-1",
"9.0.0-1",
"9.0.0-2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-58367.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.1.1-4+deb13u1"
}
]
}
],
"package": {
"name": "deepdiff",
"purl": "pkg:deb/debian/deepdiff?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"8.1.1-4"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-58367.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "8.6.1-1"
}
]
}
],
"package": {
"name": "deepdiff",
"purl": "pkg:deb/debian/deepdiff?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"8.1.1-4"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2025-58367.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:04:37.391644106Z",
"provider": "osv",
"upstream": [
"CVE-2025-58367"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2025-58367"
]
},
"related_cves": [
{
"value": "CVE-2025-58367",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 423588,
"published_at": "2025-09-05T22:15:34.71+00:00"
}