Hustle <= 7.8.14.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Module Content Title
The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content[title]' parameter in all versions up to, and including, 7.8.14.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has explicitly granted the 'Create and Update Modules' (hustle_create / hustle_edit_module) capability to the attacker's role via the plugin's own Settings → Permissions feature; this delegation is not enabled by default.
- Products
- Hustle – Email Marketing, Lead Generation, Optins, Popups
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-107710
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 17:17 UTC · Revision 1
Source evidence
Hustle <= 7.8.14.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Module Content Title
core-cve · Original sourcePublished 28 Oct 2026, 06:45 UTC
The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content[title]' parameter in all versions up to, and including, 7.8.14.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has explicitly granted the 'Create and Update Modules' (hustle_create / hustle_edit_module) capability to the attacker's role via the plugin's own Settings → Permissions feature; this delegation is not enabled by default.
cve:CVE-2026-107710
Hustle – Email Marketing, Lead Generation, Optins, Popups
Fixed versions: Not specified
Complete source record
{
"id": "780cec324a2c9749ccd51ae4728c0dfd29c6b5674f2c89d869aaeb035a014da2",
"url": "https://www.cve.org/CVERecord?id=CVE-2026-107710",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Hustle <= 7.8.14.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Module Content Title",
"summary": "The Hustle – Email Marketing, Lead Generation, Optins, Popups plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'content[title]' parameter in all versions up to, and including, 7.8.14.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with custom-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has explicitly granted the 'Create and Update Modules' (hustle_create / hustle_edit_module) capability to the attacker's role via the plugin's own Settings → Permissions feature; this delegation is not enabled by default.",
"evidence": "cve:CVE-2026-107710",
"products": [
{
"name": {
"value": "Hustle – Email Marketing, Lead Generation, Optins, Popups",
"evidence": "/containers/cna/affected/0/product"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "CVE-2026-107710",
"aliases": [
"CVE-2026-107710"
],
"metrics": [
{
"cvssV3_1": {
"version": "3.1",
"baseScore": 6.4,
"baseSeverity": "MEDIUM",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N"
}
}
],
"affected": [
{
"vendor": "wpmudev",
"product": "Hustle – Email Marketing, Lead Generation, Optins, Popups",
"versions": [
{
"status": "affected",
"version": "0",
"versionType": "semver",
"lessThanOrEqual": "7.8.14.3"
}
],
"defaultStatus": "unaffected"
}
],
"modified": "2026-10-28T16:09:34.692Z",
"provider": "cve",
"references": [
"https://www.wordfence.com/threat-intel/vulnerabilities/id/a3ed1a2a-f9d5-4f34-8a8e-583ea7226df8?source=cve",
"https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/front/hustle-module-renderer.php#L181",
"https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/front/hustle-module-renderer.php#L163",
"https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/hustle-module-model.php#L569",
"https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/hustle-modules-common-admin-ajax.php#L49",
"https://plugins.trac.wordpress.org/browser/wordpress-popup/tags/7.8.14.3/inc/front/hustle-module-front.php#L917",
"https://plugins.trac.wordpress.org/changeset/3758337/wordpress-popup/trunk/inc/front/hustle-module-renderer.php"
],
"provider_metadata": {
"adp": [
{
"title": "CISA ADP Vulnrichment",
"metrics": [
{
"other": {
"type": "ssvc",
"content": {
"id": "CVE-2026-107710",
"role": "CISA Coordinator",
"options": [
{
"Exploitation": "none"
},
{
"Automatable": "no"
},
{
"Technical Impact": "partial"
}
],
"version": "2.0.3",
"timestamp": "2026-10-28T14:36:38.020063Z"
}
}
}
],
"providerMetadata": {
"orgId": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"shortName": "CISA-ADP",
"dateUpdated": "2026-10-28T16:09:34.692Z"
}
}
],
"cna": {
"orgId": "b15e7b5b-3da4-40ae-a43c-f7aa60e62599",
"shortName": "Wordfence",
"dateUpdated": "2026-10-28T06:45:18.336Z"
}
}
},
"related_cves": [
{
"value": "CVE-2026-107710",
"evidence": "/cveMetadata/cveId"
}
],
"security_relevant": true,
"severity_evidence": "/containers/cna/metrics"
},
"source_id": "core-cve",
"document_id": 460262,
"published_at": "2026-10-28T06:45:18.336+00:00"
}