Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-15154

OS command injection occurring in versions of OpenEMR before 5.0.1.4 allows a remote authenticated attacker to execute arbitrary commands by making a crafted request to interface/billing/sl_eob_search.php after modifying the "print_command" global variable in interface/super/edit_globals.php.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-15154
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 10:03 UTC · Revision 1

Source evidence

CVE-2018-15154

core-osv · Original source

Published 15 Aug 2018, 17:29 UTC

OS command injection occurring in versions of OpenEMR before 5.0.1.4 allows a remote authenticated attacker to execute arbitrary commands by making a crafted request to interface/billing/sl_eob_search.php after modifying the "print_command" global variable in interface/super/edit_globals.php.

osv:CVE-2018-15154
Complete source record
{
  "id": "e600517060bd2ac4fe8472ba9a9ae1045e8b2c062dca86ecdba617e310211637",
  "url": "https://osv.dev/vulnerability/CVE-2018-15154",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-15154",
    "summary": "OS command injection occurring in versions of OpenEMR before 5.0.1.4 allows a remote authenticated attacker to execute arbitrary commands by making a crafted request to interface/billing/sl_eob_search.php after modifying the \"print_command\" global variable in interface/super/edit_globals.php.",
    "evidence": "osv:CVE-2018-15154",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2018-15154",
      "aliases": [
        "CVE-2018-15154"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/openemr/openemr",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "8f6b1724e1a71df6a4c2ba0aeaf900a877b20546"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:open-emr:openemr:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.0.1.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v5_0_1_3",
            "v5_0_1_2",
            "v5_0_1_1",
            "v5_0_1",
            "v3_0_1",
            "v3_0_0",
            "v2_9_0",
            "v2_8_3",
            "v2_8_2",
            "v2_8_1",
            "v2_8_0",
            "v2_7_3-rc1",
            "v2_7_2",
            "v2_7_2-rc2",
            "v2_7_2-rc1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-15154.json"
          }
        }
      ],
      "modified": "2026-10-20T10:49:49.164594687Z",
      "provider": "osv",
      "references": [
        "https://insecurity.sh/reports/openemr.pdf",
        "https://www.databreaches.net/openemr-patches-serious-vulnerabilities-uncovered-by-project-insecurity/",
        "https://github.com/openemr/openemr/pull/1757",
        "https://www.open-emr.org/wiki/index.php/OpenEMR_Patches"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-15154",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 380833,
  "published_at": "2018-08-15T17:29:02.11+00:00"
}