phpMyFAQ - Insufficient Authorization Check in Admin API Endpoints
phpMyFAQ before 4.1.2 contains an insufficient authorization vulnerability in admin-api routes that allows authenticated ordinary users to access administrative endpoints by only checking login status instead of verifying backend privileges. Attackers with valid frontend user accounts can access sensitive backend operational information including dashboard versions, LDAP configuration, Elasticsearch statistics, and health-check data.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-45009
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 10:57 UTC · Revision 1
Source evidence
phpMyFAQ - Insufficient Authorization Check in Admin API Endpoints
core-osv · Original sourcePublished 15 May 2026, 18:36 UTC
phpMyFAQ before 4.1.2 contains an insufficient authorization vulnerability in admin-api routes that allows authenticated ordinary users to access administrative endpoints by only checking login status instead of verifying backend privileges. Attackers with valid frontend user accounts can access sensitive backend operational information including dashboard versions, LDAP configuration, Elasticsearch statistics, and health-check data.
osv:CVE-2026-45009
Complete source record
{
"id": "e4533b5c41cb0247976a81406f03fd6639f66600cf1737384fca882bcb3155e5",
"url": "https://osv.dev/vulnerability/CVE-2026-45009",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "phpMyFAQ - Insufficient Authorization Check in Admin API Endpoints",
"summary": "phpMyFAQ before 4.1.2 contains an insufficient authorization vulnerability in admin-api routes that allows authenticated ordinary users to access administrative endpoints by only checking login status instead of verifying backend privileges. Attackers with valid frontend user accounts can access sensitive backend operational information including dashboard versions, LDAP configuration, Elasticsearch statistics, and health-check data.",
"evidence": "osv:CVE-2026-45009",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-45009",
"aliases": [
"CVE-2026-45009",
"GHSA-jrc5-w569-h7h5"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/thorsten/phpmyfaq",
"type": "GIT",
"events": [
{
"introduced": "f791858b2aa4b811f5b19d10c20ba5c4a30786de"
},
{
"fixed": "66792f2575b07d65896b504d47deb5f4f903f9ff"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "4.1.1"
},
{
"fixed": "4.1.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "4.1.2"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"4.1.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-45009.json"
}
}
],
"modified": "2026-10-28T02:30:28.173295615Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45009.json",
"https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-jrc5-w569-h7h5",
"https://nvd.nist.gov/vuln/detail/CVE-2026-45009",
"https://www.vulncheck.com/advisories/phpmyfaq-insufficient-authorization-check-in-admin-api-endpoints"
],
"provider_metadata": {
"cwe_ids": [
"CWE-863"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/45xxx/CVE-2026-45009.json"
}
},
"related_cves": [
{
"value": "CVE-2026-45009",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 494781,
"published_at": "2026-05-15T18:36:36.621+00:00"
}