High
ruby-thrift — security advisory
Uncaught exception, Improper Handling of Exceptional Conditions vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
- Products
- ruby-thrift
- Affected versions
- 0.11.0.0-2, 0.11.0.0-2build1, 0.11.0.0-3, 0.14.0-2, 0.14.0-2build1, 0.14.0-3, 0.16.0-2, 0.16.0-2build1, 0.16.0-2build2
- Fixed versions
- Not specified
- CVEs
- CVE-2026-96277
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 09:03 UTC · Revision 1
Source evidence
Uncaught exception, Improper Handling of Exceptional Conditions vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
osv:UBUNTU-CVE-2026-96277
ruby-thrift
Fixed versions: Not specified
ruby-thrift
Fixed versions: Not specified
ruby-thrift
Fixed versions: Not specified
Complete source record
{
"id": "233bb56fa961ec93bbed551a23b9653ac9bd85a3f4630dc818990e2656354f55",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-96277",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-96277",
"summary": "Uncaught exception, Improper Handling of Exceptional Conditions vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.",
"evidence": "osv:UBUNTU-CVE-2026-96277",
"products": [
{
"name": {
"value": "ruby-thrift",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.11.0.0-2",
"evidence": "/affected/0/versions"
},
{
"value": "0.11.0.0-2build1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "ruby-thrift",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.11.0.0-3",
"evidence": "/affected/1/versions"
},
{
"value": "0.14.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "0.14.0-2build1",
"evidence": "/affected/1/versions"
},
{
"value": "0.14.0-3",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "ruby-thrift",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "0.16.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "0.16.0-2build1",
"evidence": "/affected/2/versions"
},
{
"value": "0.16.0-2build2",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2026-96277",
"aliases": [
"UBUNTU-CVE-2026-96277"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby-thrift",
"purl": "pkg:deb/ubuntu/ruby-thrift?arch=source&distro=focal",
"ecosystem": "Ubuntu:20.04:LTS"
},
"versions": [
"0.11.0.0-2",
"0.11.0.0-2build1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-96277.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "ruby-thrift",
"binary_version": "0.11.0.0-2build1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby-thrift",
"purl": "pkg:deb/ubuntu/ruby-thrift?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"0.11.0.0-3",
"0.14.0-2",
"0.14.0-2build1",
"0.14.0-3"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-96277.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "ruby-thrift",
"binary_version": "0.14.0-3"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "ruby-thrift",
"purl": "pkg:deb/ubuntu/ruby-thrift?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"0.16.0-2",
"0.16.0-2build1",
"0.16.0-2build2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-96277.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "ruby-thrift",
"binary_version": "0.16.0-2build2"
}
]
}
}
],
"modified": "2026-10-08T09:52:15Z",
"provider": "osv",
"upstream": [
"CVE-2026-96277"
],
"references": [
"https://ubuntu.com/security/CVE-2026-96277",
"https://www.cve.org/CVERecord?id=CVE-2026-96277",
"https://lists.apache.org/thread/k1t5r9sz7k5tn57cnf5khw2ywlxv6098",
"https://lists.apache.org/thread/33otcgbqd27wf6qq810q56znzbomnhg1"
]
},
"related_cves": [
{
"value": "CVE-2026-96277",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 98923,
"published_at": "2026-10-02T13:18:00+00:00"
}