node-undici — security advisory
Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.
- Products
- node-undici
- Affected versions
- 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1, 5.26.3+dfsg1+~cs23.10.12-2, 7.16.0+dfsg+~cs3.2.0-2, 7.18.2+dfsg+~cs3.2.0-1, 7.18.2+dfsg+~cs3.2.0-1build1, 7.24.6+dfsg+~cs3.2.0-3, 7.3.0+dfsg1+~cs24.12.11-1, 7.3.0+dfsg1+~cs24.12.11-2, 8.5.0+dfsg+~cs3.2.0-2, 8.5.0+dfsg+~cs3.2.0-3, 8.9.0+dfsg+~cs3.2.0-1
- Fixed versions
- Not specified
- CVEs
- CVE-2025-47279
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 01:30 UTC · Revision 1
Source evidence
Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.
osv:UBUNTU-CVE-2025-47279
node-undici
Fixed versions: Not specified
node-undici
Fixed versions: Not specified
node-undici
Fixed versions: Not specified
node-undici
Fixed versions: Not specified
Complete source record
{
"id": "e0cf42ed3a6c564649555b455b8ef208677f4c009cf53fb4d259b4c8bfb98a9a",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2025-47279",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2025-47279",
"summary": "Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.",
"evidence": "osv:UBUNTU-CVE-2025-47279",
"products": [
{
"name": {
"value": "node-undici",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "5.26.3+dfsg1+~cs23.10.12-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "node-undici",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "7.3.0+dfsg1+~cs24.12.11-1",
"evidence": "/affected/1/versions"
},
{
"value": "7.3.0+dfsg1+~cs24.12.11-2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "node-undici",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "7.18.2+dfsg+~cs3.2.0-1build1",
"evidence": "/affected/2/versions"
},
{
"value": "7.24.6+dfsg+~cs3.2.0-3",
"evidence": "/affected/2/versions"
},
{
"value": "8.5.0+dfsg+~cs3.2.0-2",
"evidence": "/affected/2/versions"
},
{
"value": "8.5.0+dfsg+~cs3.2.0-3",
"evidence": "/affected/2/versions"
},
{
"value": "8.9.0+dfsg+~cs3.2.0-1",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "node-undici",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "7.3.0+dfsg1+~cs24.12.11-2",
"evidence": "/affected/3/versions"
},
{
"value": "7.16.0+dfsg+~cs3.2.0-2",
"evidence": "/affected/3/versions"
},
{
"value": "7.18.2+dfsg+~cs3.2.0-1",
"evidence": "/affected/3/versions"
},
{
"value": "7.18.2+dfsg+~cs3.2.0-1build1",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "low",
"structured": {
"id": "UBUNTU-CVE-2025-47279",
"aliases": [
"UBUNTU-CVE-2025-47279"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-undici",
"purl": "pkg:deb/ubuntu/node-undici?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1",
"5.26.3+dfsg1+~cs23.10.12-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-47279.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-llhttp",
"binary_version": "9.1.3~5.26.3+dfsg1+~cs23.10.12-2"
},
{
"binary_name": "node-undici",
"binary_version": "5.26.3+dfsg1+~cs23.10.12-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-undici",
"purl": "pkg:deb/ubuntu/node-undici?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"7.3.0+dfsg1+~cs24.12.11-1",
"7.3.0+dfsg1+~cs24.12.11-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-47279.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libllhttp9.2",
"binary_version": "9.2.1~7.3.0+dfsg1+~cs24.12.11-2"
},
{
"binary_name": "node-llhttp",
"binary_version": "9.2.1~7.3.0+dfsg1+~cs24.12.11-2"
},
{
"binary_name": "node-undici",
"binary_version": "7.3.0+dfsg1+~cs24.12.11-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-undici",
"purl": "pkg:deb/ubuntu/node-undici?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"7.18.2+dfsg+~cs3.2.0-1build1",
"7.24.6+dfsg+~cs3.2.0-3",
"8.5.0+dfsg+~cs3.2.0-2",
"8.5.0+dfsg+~cs3.2.0-3",
"8.9.0+dfsg+~cs3.2.0-1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-47279.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-undici",
"binary_version": "8.9.0+dfsg+~cs3.2.0-1"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-undici",
"purl": "pkg:deb/ubuntu/node-undici?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"7.3.0+dfsg1+~cs24.12.11-2",
"7.16.0+dfsg+~cs3.2.0-2",
"7.18.2+dfsg+~cs3.2.0-1",
"7.18.2+dfsg+~cs3.2.0-1build1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-47279.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-undici",
"binary_version": "7.18.2+dfsg+~cs3.2.0-1build1"
}
]
}
}
],
"modified": "2026-10-17T12:56:59.336786736Z",
"provider": "osv",
"upstream": [
"CVE-2025-47279"
],
"references": [
"https://ubuntu.com/security/CVE-2025-47279",
"https://www.cve.org/CVERecord?id=CVE-2025-47279",
"https://github.com/nodejs/undici/security/advisories/GHSA-cxrh-j4jr-qwg3",
"https://github.com/nodejs/undici/issues/3895",
"https://github.com/nodejs/undici/pull/4088"
]
},
"related_cves": [
{
"value": "CVE-2025-47279",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 356600,
"published_at": "2025-05-15T18:15:00+00:00"
}