User Group Privilege Escalation
A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-34158
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 19:31 UTC · Revision 1
Source evidence
A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.
osv:CVE-2022-34158
Complete source record
{
"id": "4ce09dd8db92084d0a623c38bc7513514cf4f6e1a41f613835dc0dfea2d1edea",
"url": "https://osv.dev/vulnerability/CVE-2022-34158",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "User Group Privilege Escalation",
"summary": "A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.",
"evidence": "osv:CVE-2022-34158",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-34158",
"aliases": [
"CVE-2022-34158",
"GHSA-jp3m-p26h-mm7v"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/jspwiki",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "515dff39c66c43318056fa76a20117662d2a0e8d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:jspwiki:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.11.3"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.11.2-RC1",
"2.11.2",
"2.11.1-RC1",
"2.11.1",
"2.11.0-RC2",
"2.11.0",
"2.11.0-RC1",
"2.11.0.M8-RC1",
"2.11.0.M8",
"2.11.0.M7-RC1",
"2.11.0.M7",
"2.11.0.M6-RC1",
"2.11.0.M6",
"2.11.0.M5-RC3",
"2.11.0.M5",
"2.11.0.M5-RC2",
"2.11.0.M5-RC1",
"2.11.0.M4-RC2",
"2.11.0.M4",
"2.11.0.M4-RC1",
"2.11.0.M3-RC2",
"2.11.0.M3",
"2.11.0.M3-RC1",
"2.11.0.M2-RC1",
"2.11.0.M2",
"2.11.0.M1.RC3",
"2.11.0.M1",
"2.11.0.M1-RC2",
"2.11.0.M1-RC1",
"2.10.5-RC2",
"2.10.5",
"2.10.5-RC1",
"2.10.4-RC3",
"2.10.4",
"2.10.4-RC2",
"2.10.4-RC1",
"2.10.3-RC2",
"2.10.3",
"2.10.3-RC1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-34158.json"
}
}
],
"modified": "2026-10-28T02:30:22.620458076Z",
"provider": "osv",
"references": [
"https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2022-34158",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/34xxx/CVE-2022-34158.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-34158"
],
"provider_metadata": {
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "Apache JSPWiki up to 2.11.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "SplitRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/34xxx/CVE-2022-34158.json"
}
},
"related_cves": [
{
"value": "CVE-2022-34158",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 489199,
"published_at": "2022-08-04T06:16:11+00:00"
}