Security advisory
The 'State' field of the Edit profile page of the LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress plugin before 4.21.1 is not properly sanitised when output in the About section of the profile page, leading to a stored Cross-Site Scripting issue. This could allow low privilege users (such as students) to elevate their privilege via an XSS attack when an admin will view their profile.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-24308
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:15 UTC · Revision 1
Source evidence
The 'State' field of the Edit profile page of the LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress plugin before 4.21.1 is not properly sanitised when output in the About section of the profile page, leading to a stored Cross-Site Scripting issue. This could allow low privilege users (such as students) to elevate their privilege via an XSS attack when an admin will view their profile.
osv:CVE-2021-24308
Complete source record
{
"id": "2477ecf45a529b2aad4c45a19fec2ff268e06a3fbd9e9fa8c88128bcb00778bc",
"url": "https://osv.dev/vulnerability/CVE-2021-24308",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-24308",
"summary": "The 'State' field of the Edit profile page of the LMS by LifterLMS – Online Course, Membership & Learning Management System Plugin for WordPress plugin before 4.21.1 is not properly sanitised when output in the About section of the profile page, leading to a stored Cross-Site Scripting issue. This could allow low privilege users (such as students) to elevate their privilege via an XSS attack when an admin will view their profile.",
"evidence": "osv:CVE-2021-24308",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-24308",
"aliases": [
"CVE-2021-24308"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gocodebox/lifterlms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "74bc6cf3f23c32814bc994ec22ce07b94d84b017"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.21.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "74bc6cf3f23c32814bc994ec22ce07b94d84b017"
}
],
"source": "REFERENCES_TAG",
"original_tag": "4.21.1"
}
]
}
}
],
"versions": [
"@lifterlms/scripts@1.3.5",
"@lifterlms/llms-e2e-test-utils@2.2.2",
"@lifterlms/llms-e2e-test-utils@2.1.3",
"@lifterlms/scripts@1.3.2",
"@lifterlms/scripts@1.3.0",
"@lifterlms/scripts@1.2.4",
"@lifterlms/scripts@1.2.3",
"@lifterlms/llms-e2e-test-utils@2.1.2",
"@lifterlms/scripts@1.2.1",
"@lifterlms/llms-e2e-test-utils@2.1.0",
"@lifterlms/scripts@1.3.1",
"@lifterlms/scripts@1.2.0",
"@lifterlms/llms-e2e-test-utils@2.0.0",
"@lifterlms/llms-e2e-test-utils@1.1.1",
"llms-e2e-test-utils@1.1.0",
"llms-e2e-test-utils@1.0.1",
"llms-e2e-test-utils@1.0.0",
"3.20.0-beta.1",
"3.0.0-beta.5",
"3.0.0-beta.4",
"3.0.0-beta.3",
"3.0.0-beta.2",
"3.0.0-beta.1",
"1.4.0",
"1.3.10",
"1.3.9",
"1.3.8",
"1.3.7",
"1.3.6",
"1.3.5",
"1.3.4",
"v1.3.3",
"1.3.2",
"1.3.0",
"1.2.6",
"1.2.5",
"1.2.4",
"1.1.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-24308.json"
}
}
],
"modified": "2026-10-20T10:53:38.799350537Z",
"provider": "osv",
"references": [
"https://github.com/gocodebox/lifterlms/releases/tag/4.21.1",
"https://wpscan.com/vulnerability/f29f68a5-6575-441d-98c9-867145f2b082"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-24308",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 384459,
"published_at": "2021-05-24T11:15:08.387+00:00"
}