Medium
Security advisory
In haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like < > " ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-1002201
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 09:49 UTC · Revision 1
Source evidence
In haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like < > " ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.
osv:CVE-2017-1002201
Complete source record
{
"id": "f533fdf27f2454e8636c4e79f561b69835e221bc8b42463694c7f26bd2eedea4",
"url": "https://osv.dev/vulnerability/CVE-2017-1002201",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-1002201",
"summary": "In haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like < > \" ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.",
"evidence": "osv:CVE-2017-1002201",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-1002201",
"aliases": [
"CVE-2017-1002201",
"GHSA-r53w-g4xm-3gc6",
"SNYK-RUBY-HAML-20362"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/haml/haml",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "78e2a09d3b8c6f7cdb3bb87ff84dce8fad5598ac"
},
{
"fixed": "18576ae6e9bdcb4303fdbe6b3199869d289d67c2"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:haml:haml:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.0.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "18576ae6e9bdcb4303fdbe6b3199869d289d67c2"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v5.0.0.beta.2",
"4.1.0.beta.1",
"3.2.0.beta.2",
"3.2.0.beta.1",
"3.1.3",
"3.1.2",
"3.1.1",
"3.1.0",
"3.0.0",
"3.0.0.rc.5",
"3.0.0.rc.4",
"3.0.0.rc.3",
"3.0.0.rc.2",
"3.0.0.rc.1",
"3.0.0.beta.3",
"3.0.0.beta.2",
"3.0.0.beta.1",
"2.2.0",
"2.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-1002201.json"
}
}
],
"modified": "2026-10-20T10:48:01.838195808Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2019/11/msg00007.html",
"https://lists.debian.org/debian-lts-announce/2021/12/msg00028.html",
"https://security.gentoo.org/glsa/202007-27",
"https://github.com/haml/haml/commit/18576ae6e9bdcb4303fdbe6b3199869d289d67c2",
"https://snyk.io/vuln/SNYK-RUBY-HAML-20362"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2017-1002201",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 379960,
"published_at": "2019-10-15T18:15:10.56+00:00"
}