Skip to content
Heist/ feed
Back to feed
Medium

node-mermaid — security advisory

Type: advisorySources: OSVAdvisory ID: UBUNTU-CVE-2026-71436

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.

Products
node-mermaid
Affected versions
8.13.3+ds+~cs26.13.21-1, 8.13.3+ds+~cs26.13.21-2, 8.13.8+~cs10.4.16-1, 8.7.0+ds+~cs27.17.17-3, 9.2.2+~2.0.0-1, 9.2.2+~2.0.0-2
Fixed versions
Not specified
CVEs
CVE-2026-71436
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 03:14 UTC · Revision 1

Source evidence

UBUNTU-CVE-2026-71436

core-osv · Original source

Published 6 Aug 2026, 22:18 UTC

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.

osv:UBUNTU-CVE-2026-71436

node-mermaid

Fixed versions: Not specified

node-mermaid

Fixed versions: Not specified

Complete source record
{
  "id": "c50a03f426778e66522e7e805ebf66d810402abd2dd63989d8ff641b8258708d",
  "url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-71436",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "UBUNTU-CVE-2026-71436",
    "summary": "Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.",
    "evidence": "osv:UBUNTU-CVE-2026-71436",
    "products": [
      {
        "name": {
          "value": "node-mermaid",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "8.7.0+ds+~cs27.17.17-3",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "8.13.3+ds+~cs26.13.21-1",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "8.13.3+ds+~cs26.13.21-2",
            "evidence": "/affected/0/versions"
          },
          {
            "value": "8.13.8+~cs10.4.16-1",
            "evidence": "/affected/0/versions"
          }
        ]
      },
      {
        "name": {
          "value": "node-mermaid",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [],
        "affected_versions": [
          {
            "value": "9.2.2+~2.0.0-1",
            "evidence": "/affected/1/versions"
          },
          {
            "value": "9.2.2+~2.0.0-2",
            "evidence": "/affected/1/versions"
          }
        ]
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "UBUNTU-CVE-2026-71436",
      "aliases": [
        "UBUNTU-CVE-2026-71436"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L"
        },
        {
          "type": "Ubuntu",
          "score": "medium"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "node-mermaid",
            "purl": "pkg:deb/ubuntu/node-mermaid?arch=source&distro=jammy",
            "ecosystem": "Ubuntu:22.04:LTS"
          },
          "versions": [
            "8.7.0+ds+~cs27.17.17-3",
            "8.13.3+ds+~cs26.13.21-1",
            "8.13.3+ds+~cs26.13.21-2",
            "8.13.8+~cs10.4.16-1"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-71436.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "node-mermaid",
                "binary_version": "8.13.8+~cs10.4.16-1"
              }
            ]
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                }
              ]
            }
          ],
          "package": {
            "name": "node-mermaid",
            "purl": "pkg:deb/ubuntu/node-mermaid?arch=source&distro=stonking",
            "ecosystem": "Ubuntu:26.10"
          },
          "versions": [
            "9.2.2+~2.0.0-1",
            "9.2.2+~2.0.0-2"
          ],
          "database_specific": {
            "source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-71436.json"
          },
          "ecosystem_specific": {
            "binaries": [
              {
                "binary_name": "node-mermaid",
                "binary_version": "9.2.2+~2.0.0-2"
              }
            ]
          }
        }
      ],
      "modified": "2026-10-17T13:00:42.150857233Z",
      "provider": "osv",
      "upstream": [
        "CVE-2026-71436"
      ],
      "references": [
        "https://ubuntu.com/security/CVE-2026-71436",
        "https://www.cve.org/CVERecord?id=CVE-2026-71436",
        "https://github.com/mermaid-js/mermaid/security/advisories/GHSA-2v8p-3f2j-5mp7",
        "https://github.com/mermaid-js/mermaid/commit/630aa7e5dd417e1f56bff2a1ce8df2c5ad08d289",
        "https://github.com/mermaid-js/mermaid/commit/ef60adc837d9d5107af21285f01e83dea309bd0a",
        "https://github.com/mermaid-js/mermaid/pull/8022",
        "https://github.com/mermaid-js/mermaid/releases/tag/mermaid@11.16.1",
        "https://github.com/mermaid-js/mermaid/releases/tag/v10.9.8"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2026-71436",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 360788,
  "published_at": "2026-08-06T22:18:00+00:00"
}