MediumFix available
spip — security advisory
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
- Products
- spip
- Affected versions
- Not specified
- Fixed versions
- 3.2.8-1
- CVEs
- CVE-2022-28959
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:55 UTC · Revision 1
Source evidence
Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.
osv:DEBIAN-CVE-2022-28959
spip
Fixed versions: 3.2.8-1
spip
Fixed versions: 3.2.8-1
Complete source record
{
"id": "5ca2d60d2693f9be75efceadd96bc6a0a26a01f5133f0a1a3446ba36d451064c",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-28959",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-28959",
"summary": "Multiple cross-site scripting (XSS) vulnerabilities in the component /spip.php of Spip Web Framework v3.1.13 and below allows attackers to execute arbitrary web scripts or HTML.",
"evidence": "osv:DEBIAN-CVE-2022-28959",
"products": [
{
"name": {
"value": "spip",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.2.8-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "spip",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.2.8-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-28959",
"aliases": [
"DEBIAN-CVE-2022-28959"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.8-1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28959.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.2.8-1"
}
]
}
],
"package": {
"name": "spip",
"purl": "pkg:deb/debian/spip?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-28959.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:37.196445700Z",
"provider": "osv",
"upstream": [
"CVE-2022-28959"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-28959"
]
},
"related_cves": [
{
"value": "CVE-2022-28959",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323778,
"published_at": "2022-05-19T21:15:08.06+00:00"
}