React-Admin vulnerable to Cross-Site-Scripting attack on ``
react-admin is a frontend framework for building browser applications on top of REST/GraphQL APIs. react-admin prior to versions 3.19.12 and 4.7.6, along with ra-ui-materialui prior to 3.19.12 and 4.7.6, are vulnerable to cross-site scripting. All React applications built with react-admin and using the `` are affected. `` outputs the field value using `dangerouslySetInnerHTML` without client-side sanitization. If the data isn't sanitized server-side, this opens a possible cross-site scripting (XSS) attack. Versions 3.19.12 and 4.7.6 now use `DOMPurify` to escape the HTML before outputting it with React and `dangerouslySetInnerHTML`. Users who already sanitize HTML data server-side do not need to upgrade. As a workaround, users may replace the `` by a custom field doing sanitization by hand.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-25572
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 20:10 UTC · Revision 1
Source evidence
React-Admin vulnerable to Cross-Site-Scripting attack on ``
core-osv · Original sourcePublished 13 Feb 2023, 20:49 UTC
react-admin is a frontend framework for building browser applications on top of REST/GraphQL APIs. react-admin prior to versions 3.19.12 and 4.7.6, along with ra-ui-materialui prior to 3.19.12 and 4.7.6, are vulnerable to cross-site scripting. All React applications built with react-admin and using the `` are affected. `` outputs the field value using `dangerouslySetInnerHTML` without client-side sanitization. If the data isn't sanitized server-side, this opens a possible cross-site scripting (XSS) attack. Versions 3.19.12 and 4.7.6 now use `DOMPurify` to escape the HTML before outputting it with React and `dangerouslySetInnerHTML`. Users who already sanitize HTML data server-side do not need to upgrade. As a workaround, users may replace the `` by a custom field doing sanitization by hand.
osv:CVE-2023-25572
Complete source record
{
"id": "0293dbf0abc394500fc4d52976aea2ea54b787977efda23048013b7996de9a65",
"url": "https://osv.dev/vulnerability/CVE-2023-25572",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "React-Admin vulnerable to Cross-Site-Scripting attack on ``",
"summary": "react-admin is a frontend framework for building browser applications on top of REST/GraphQL APIs. react-admin prior to versions 3.19.12 and 4.7.6, along with ra-ui-materialui prior to 3.19.12 and 4.7.6, are vulnerable to cross-site scripting. All React applications built with react-admin and using the `` are affected. `` outputs the field value using `dangerouslySetInnerHTML` without client-side sanitization. If the data isn't sanitized server-side, this opens a possible cross-site scripting (XSS) attack. Versions 3.19.12 and 4.7.6 now use `DOMPurify` to escape the HTML before outputting it with React and `dangerouslySetInnerHTML`. Users who already sanitize HTML data server-side do not need to upgrade. As a workaround, users may replace the `` by a custom field doing sanitization by hand.",
"evidence": "osv:CVE-2023-25572",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-25572",
"aliases": [
"CVE-2023-25572",
"GHSA-5jcr-82fh-339v"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/marmelab/react-admin",
"type": "GIT",
"events": [
{
"introduced": "712c2f2ad48f90270567c49e662c0f4d03551268"
},
{
"fixed": "ebe2e35320bb6882f6adba7831f4799809a11f28"
},
{
"fixed": "d295fc971a11cb13174405a50b08826d0de22e67"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:marmelab:ra-ui-materialui:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.7.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:marmelab:react-admin:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.7.6"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "d295fc971a11cb13174405a50b08826d0de22e67"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v3.19.12"
},
{
"range": [
{
"fixed": "ebe2e35320bb6882f6adba7831f4799809a11f28"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v4.7.6"
}
]
}
}
],
"versions": [
"v4.7.5",
"v4.7.4",
"v4.7.3",
"v4.7.2",
"v4.7.1",
"v4.7.0",
"v4.6.3",
"v4.6.2",
"v4.6.1",
"v4.6.0",
"v4.5.4",
"v4.5.3",
"v4.5.2",
"v4.5.1",
"v4.5.0",
"v4.4.4",
"v4.4.3",
"v4.4.2",
"v4.4.1",
"v4.4.0",
"v4.3.4",
"v4.3.3",
"v4.3.2",
"v4.3.1",
"v4.3.0",
"v4.2.2",
"v4.2.1",
"v4.2.0",
"v4.0.1",
"v4.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-25572.json"
}
}
],
"modified": "2026-10-28T02:30:32.089400049Z",
"provider": "osv",
"references": [
"https://github.com/marmelab/react-admin/releases/tag/v3.19.12",
"https://github.com/marmelab/react-admin/releases/tag/v4.7.6",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/25xxx/CVE-2023-25572.json",
"https://github.com/marmelab/react-admin/security/advisories/GHSA-5jcr-82fh-339v",
"https://nvd.nist.gov/vuln/detail/CVE-2023-25572",
"https://github.com/marmelab/react-admin/pull/8644",
"https://github.com/marmelab/react-admin/pull/8645"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/25xxx/CVE-2023-25572.json"
}
},
"related_cves": [
{
"value": "CVE-2023-25572",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 498905,
"published_at": "2023-02-13T20:49:54.34+00:00"
}