UnratedFix available
libgd2 — security advisory
The gdImageCreateFromXpm function in gdxpm.c in libgd, as used in PHP 5.4.26 and earlier, allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted color table in an XPM file.
- Products
- libgd2
- Affected versions
- Not specified
- Fixed versions
- 2.1.0-4
- CVEs
- CVE-2014-2497
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:47 UTC · Revision 1
Source evidence
The gdImageCreateFromXpm function in gdxpm.c in libgd, as used in PHP 5.4.26 and earlier, allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted color table in an XPM file.
osv:DEBIAN-CVE-2014-2497
libgd2
Fixed versions: 2.1.0-4
libgd2
Fixed versions: 2.1.0-4
libgd2
Fixed versions: 2.1.0-4
Complete source record
{
"id": "9832f20e158c352986c76e244d07fb8e5ed0c1c60b44adbd55b7729fa2e439f6",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-2497",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-2497",
"summary": "The gdImageCreateFromXpm function in gdxpm.c in libgd, as used in PHP 5.4.26 and earlier, allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted color table in an XPM file.",
"evidence": "osv:DEBIAN-CVE-2014-2497",
"products": [
{
"name": {
"value": "libgd2",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.1.0-4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libgd2",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.1.0-4",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libgd2",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.1.0-4",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-2497",
"aliases": [
"DEBIAN-CVE-2014-2497"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1.0-4"
}
]
}
],
"package": {
"name": "libgd2",
"purl": "pkg:deb/debian/libgd2?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-2497.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1.0-4"
}
]
}
],
"package": {
"name": "libgd2",
"purl": "pkg:deb/debian/libgd2?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-2497.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1.0-4"
}
]
}
],
"package": {
"name": "libgd2",
"purl": "pkg:deb/debian/libgd2?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-2497.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-23T15:47:38.074045761Z",
"provider": "osv",
"upstream": [
"CVE-2014-2497"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-2497"
]
},
"related_cves": [
{
"value": "CVE-2014-2497",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 414442,
"published_at": "2014-03-21T14:55:12.567+00:00"
}