Apache Linkis DatasourceManager module has a deserialization command execution
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-29216
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 03:05 UTC · Revision 1
Source evidence
Apache Linkis DatasourceManager module has a deserialization command execution
core-osv · Original sourcePublished 10 Apr 2023, 07:37 UTC
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
osv:CVE-2023-29216
Complete source record
{
"id": "37092b918265d95fb72a9e6930d7a9876ba0e93e1bef1ea5c2eebfe5935ac10f",
"url": "https://osv.dev/vulnerability/CVE-2023-29216",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Linkis DatasourceManager module has a deserialization command execution",
"summary": "In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.",
"evidence": "osv:CVE-2023-29216",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2023-29216",
"aliases": [
"CVE-2023-29216",
"GHSA-rrhf-32rq-f28h"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/linkis",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "8e804ff2e3c2ef55b92a206c38b6a9925f466670"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:linkis:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"last_affected": "1.3.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.3.1",
"1.0.2",
"1.0.1",
"1.0.0",
"1.0.0-RC1",
"0.11.0",
"0.10.0",
"0.9.4",
"0.9.3",
"0.9.2",
"0.9.1",
"0.8.0",
"0.7.0",
"0.6.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-29216.json"
}
}
],
"modified": "2026-10-28T02:30:49.146475389Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/29xxx/CVE-2023-29216.json",
"https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l",
"https://nvd.nist.gov/vuln/detail/CVE-2023-29216"
],
"provider_metadata": {
"cwe_ids": [
"CWE-502"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "1.3.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/29xxx/CVE-2023-29216.json"
}
},
"related_cves": [
{
"value": "CVE-2023-29216",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517611,
"published_at": "2023-04-10T07:37:29.383+00:00"
}