Cross-site Scripting in BookWyrm
Bookwyrm is an open source social reading and reviewing program. Versions of Bookwyrm prior to 0.4.1 did not properly sanitize html being rendered to users. Unprivileged users are able to inject scripts into user profiles, book descriptions, and statuses. These vulnerabilities may be exploited as cross site scripting attacks on users viewing these fields. Users are advised to upgrade to version 0.4.1. There are no known workarounds for this issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-31136
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 19:09 UTC · Revision 1
Source evidence
Bookwyrm is an open source social reading and reviewing program. Versions of Bookwyrm prior to 0.4.1 did not properly sanitize html being rendered to users. Unprivileged users are able to inject scripts into user profiles, book descriptions, and statuses. These vulnerabilities may be exploited as cross site scripting attacks on users viewing these fields. Users are advised to upgrade to version 0.4.1. There are no known workarounds for this issue.
osv:CVE-2022-31136
Complete source record
{
"id": "69a4abe8cd8bd21a6ca5a60b2927f797a0424077b29ac1e5902a503910bc89d6",
"url": "https://osv.dev/vulnerability/CVE-2022-31136",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Cross-site Scripting in BookWyrm",
"summary": "Bookwyrm is an open source social reading and reviewing program. Versions of Bookwyrm prior to 0.4.1 did not properly sanitize html being rendered to users. Unprivileged users are able to inject scripts into user profiles, book descriptions, and statuses. These vulnerabilities may be exploited as cross site scripting attacks on users viewing these fields. Users are advised to upgrade to version 0.4.1. There are no known workarounds for this issue.",
"evidence": "osv:CVE-2022-31136",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-31136",
"aliases": [
"CVE-2022-31136",
"GHSA-2cfh-v7rf-pxfp"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/bookwyrm-social/bookwyrm",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "e452aa95b658fbb9672f746185488b10a1114f14"
},
{
"fixed": "fe33fdcf564a6a5667aef75d5456bea08feab50d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:joinbookwyrm:bookwyrm:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "0.4.1"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "fe33fdcf564a6a5667aef75d5456bea08feab50d"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v0.4.0",
"v0.3.4",
"v0.3.3",
"v0.3.2",
"v0.3.1",
"v0.3.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-31136.json"
}
}
],
"modified": "2026-10-28T02:30:47.901461857Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31136.json",
"https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-2cfh-v7rf-pxfp",
"https://nvd.nist.gov/vuln/detail/CVE-2022-31136",
"https://github.com/bookwyrm-social/bookwyrm/commit/fe33fdcf564a6a5667aef75d5456bea08feab50d"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31136.json"
}
},
"related_cves": [
{
"value": "CVE-2022-31136",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 515947,
"published_at": "2022-07-07T17:55:13+00:00"
}