Skip to content
Heist/ feed
Back to feed
Medium

WordPress WPZOOM Addons for Elementor plugin <= 1.1.35 - Cross Site Scripting (XSS) vulnerability

Type: advisorySources: OSV

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPZOOM WPZOOM Addons for Elementor (Templates, Widgets) allows Stored XSS.This issue affects WPZOOM Addons for Elementor (Templates, Widgets): from n/a through 1.1.35.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-33539
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 15:39 UTC · Revision 1

Source evidence

WordPress WPZOOM Addons for Elementor plugin <= 1.1.35 - Cross Site Scripting (XSS) vulnerability

core-osv · Original source

Published 29 Apr 2024, 05:23 UTC

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPZOOM WPZOOM Addons for Elementor (Templates, Widgets) allows Stored XSS.This issue affects WPZOOM Addons for Elementor (Templates, Widgets): from n/a through 1.1.35.

osv:CVE-2024-33539
Complete source record
{
  "id": "e2292da80f46ab83db1e97bdf87efcc4cb6005ee51cd6718a700be7642b8e10b",
  "url": "https://osv.dev/vulnerability/CVE-2024-33539",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WordPress WPZOOM Addons for Elementor plugin <= 1.1.35 - Cross Site Scripting (XSS) vulnerability",
    "summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPZOOM WPZOOM Addons for Elementor (Templates, Widgets) allows Stored XSS.This issue affects WPZOOM Addons for Elementor (Templates, Widgets): from n/a through 1.1.35.",
    "evidence": "osv:CVE-2024-33539",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-33539",
      "aliases": [
        "CVE-2024-33539"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wpzoom/wpzoom-elementor-addons",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "88b9980c964eab59bad8e52f012e008d815f77c3"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wpzoom:wpzoom_elementor_addons:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.1.36"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "1.1.35",
            "1.1.34",
            "1.1.33",
            "1.1.32",
            "1.1.31",
            "1.1.30",
            "1.1.29",
            "1.1.28",
            "1.1.27",
            "1.1.26",
            "1.1.25",
            "1.1.24",
            "1.1.23",
            "1.1.22",
            "1.1.21",
            "1.1.20",
            "1.1.19",
            "1.1.18",
            "1.1.17",
            "1.1.16",
            "1.1.15"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-33539.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:30.077614402Z",
      "provider": "osv",
      "references": [
        "https://wordpress.org/plugins",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/33xxx/CVE-2024-33539.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-33539",
        "https://patchstack.com/database/vulnerability/wpzoom-elementor-addons/wordpress-wpzoom-addons-for-elementor-plugin-1-1-35-cross-site-scripting-xss-vulnerability?_s_id=cve"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "Patchstack",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.1.36"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "ChangesAt"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/33xxx/CVE-2024-33539.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-33539",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 496909,
  "published_at": "2024-04-29T05:23:30.661+00:00"
}