UnratedFix available
cacti, libphp-adodb — security advisory
SQL injection vulnerability in ADOdb before 4.71, when using PostgreSQL, allows remote attackers to execute arbitrary SQL commands via unspecified attack vectors involving binary strings.
- Products
- cacti, libphp-adodb
- Affected versions
- Not specified
- Fixed versions
- 0.8.6d-1, 4.72-0.1
- CVEs
- CVE-2006-0410
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:11 UTC · Revision 1
Source evidence
SQL injection vulnerability in ADOdb before 4.71, when using PostgreSQL, allows remote attackers to execute arbitrary SQL commands via unspecified attack vectors involving binary strings.
osv:DEBIAN-CVE-2006-0410
cacti
Fixed versions: 0.8.6d-1
cacti
Fixed versions: 0.8.6d-1
cacti
Fixed versions: 0.8.6d-1
libphp-adodb
Fixed versions: 4.72-0.1
libphp-adodb
Fixed versions: 4.72-0.1
libphp-adodb
Fixed versions: 4.72-0.1
Complete source record
{
"id": "99999c3b484c68d43bb31f9563c6bd88b3f3187f96faf5e659e1240f96adbd77",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2006-0410",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2006-0410",
"summary": "SQL injection vulnerability in ADOdb before 4.71, when using PostgreSQL, allows remote attackers to execute arbitrary SQL commands via unspecified attack vectors involving binary strings.",
"evidence": "osv:DEBIAN-CVE-2006-0410",
"products": [
{
"name": {
"value": "cacti",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.8.6d-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "cacti",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.8.6d-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "cacti",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.8.6d-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libphp-adodb",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.72-0.1",
"evidence": "/affected/3/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libphp-adodb",
"evidence": "/affected/4/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.72-0.1",
"evidence": "/affected/4/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "libphp-adodb",
"evidence": "/affected/5/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.72-0.1",
"evidence": "/affected/5/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2006-0410",
"aliases": [
"DEBIAN-CVE-2006-0410"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8.6d-1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-0410.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8.6d-1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-0410.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.8.6d-1"
}
]
}
],
"package": {
"name": "cacti",
"purl": "pkg:deb/debian/cacti?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-0410.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.72-0.1"
}
]
}
],
"package": {
"name": "libphp-adodb",
"purl": "pkg:deb/debian/libphp-adodb?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-0410.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.72-0.1"
}
]
}
],
"package": {
"name": "libphp-adodb",
"purl": "pkg:deb/debian/libphp-adodb?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-0410.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "4.72-0.1"
}
]
}
],
"package": {
"name": "libphp-adodb",
"purl": "pkg:deb/debian/libphp-adodb?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2006-0410.json"
},
"ecosystem_specific": {
"urgency": "medium"
}
}
],
"modified": "2026-10-22T23:47:22.380294265Z",
"provider": "osv",
"upstream": [
"CVE-2006-0410"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2006-0410"
]
},
"related_cves": [
{
"value": "CVE-2006-0410",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 410350,
"published_at": "2006-01-25T02:03:00+00:00"
}