Skip to content
Heist/ feed
Back to feed
HighFix available

libreoffice — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-26305

An Improper Certificate Validation vulnerability in LibreOffice existed where determining if a macro was signed by a trusted author was done by only matching the serial number and issuer string of the used certificate with that of a trusted certificate. This is not sufficient to verify that the macro was actually signed with the certificate. An adversary could therefore create an arbitrary certificate with a serial number and an issuer string identical to a trusted certificate which LibreOffice would present as belonging to the trusted author, potentially leading to the user to execute arbitrary code contained in macros improperly trusted. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1.

Products
libreoffice
Affected versions
Not specified
Fixed versions
1:7.3.2~rc2-1
CVEs
CVE-2022-26305
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:48 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-26305

core-osv · Original source

Published 25 Jul 2022, 15:15 UTC

An Improper Certificate Validation vulnerability in LibreOffice existed where determining if a macro was signed by a trusted author was done by only matching the serial number and issuer string of the used certificate with that of a trusted certificate. This is not sufficient to verify that the macro was actually signed with the certificate. An adversary could therefore create an arbitrary certificate with a serial number and an issuer string identical to a trusted certificate which LibreOffice would present as belonging to the trusted author, potentially leading to the user to execute arbitrary code contained in macros improperly trusted. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1.

osv:DEBIAN-CVE-2022-26305

libreoffice

Fixed versions: 1:7.3.2~rc2-1

libreoffice

Fixed versions: 1:7.3.2~rc2-1

libreoffice

Fixed versions: 1:7.3.2~rc2-1

Complete source record
{
  "id": "3603ba89e99ec741f063f8a58d57695c239e471f30c2965e4c8336302e955c29",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-26305",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-26305",
    "summary": "An Improper Certificate Validation vulnerability in LibreOffice existed where determining if a macro was signed by a trusted author was done by only matching the serial number and issuer string of the used certificate with that of a trusted certificate. This is not sufficient to verify that the macro was actually signed with the certificate. An adversary could therefore create an arbitrary certificate with a serial number and an issuer string identical to a trusted certificate which LibreOffice would present as belonging to the trusted author, potentially leading to the user to execute arbitrary code contained in macros improperly trusted. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.1.",
    "evidence": "osv:DEBIAN-CVE-2022-26305",
    "products": [
      {
        "name": {
          "value": "libreoffice",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:7.3.2~rc2-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libreoffice",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:7.3.2~rc2-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libreoffice",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:7.3.2~rc2-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2022-26305",
      "aliases": [
        "DEBIAN-CVE-2022-26305"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:7.3.2~rc2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libreoffice",
            "purl": "pkg:deb/debian/libreoffice?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-26305.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:7.3.2~rc2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libreoffice",
            "purl": "pkg:deb/debian/libreoffice?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-26305.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:7.3.2~rc2-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libreoffice",
            "purl": "pkg:deb/debian/libreoffice?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-26305.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:02:15.635059334Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-26305"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-26305"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-26305",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323337,
  "published_at": "2022-07-25T15:15:09.303+00:00"
}