Security advisory
In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-20717
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:53 UTC · Revision 1
Source evidence
In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.
osv:CVE-2018-20717
Complete source record
{
"id": "90cd640366643768afa42ecdcc830276619b2a6080b8549aade7b51bfa765601",
"url": "https://osv.dev/vulnerability/CVE-2018-20717",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-20717",
"summary": "In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.",
"evidence": "osv:CVE-2018-20717",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-20717",
"aliases": [
"CVE-2018-20717",
"GHSA-xx67-2j3v-h76p"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/prestashop/prestashop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "1bd0f2291a5060cd00b15aa15a78cfd10198e062"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.7.2.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.7.2.0",
"1.7.2.4",
"1.7.2.3",
"1.7.2.2",
"1.7.2.1",
"1.7.2.0-rc.1.0",
"1.7.0.0-rc.0.0",
"1.7.0.0-beta.4.0",
"1.7.0.0-beta.2.0",
"1.7.0.0-beta.1.0",
"1.6.1.0",
"1.6.0.3",
"1.6.0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-20717.json"
}
}
],
"modified": "2026-10-24T10:30:59.996587435Z",
"provider": "osv",
"references": [
"https://build.prestashop.com/news/prestashop-1-7-2-5-maintenance-release/",
"https://blog.ripstech.com/2018/prestashop-remote-code-execution/"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:*"
],
"vendor_product": "prestashop:prestashop",
"extracted_events": [
{
"range": [
{
"fixed": "1.7.2.5"
}
],
"source": "CPE_RANGE"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-20717",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 439440,
"published_at": "2019-01-15T16:29:00.603+00:00"
}