Skip to content
Heist/ feed
Back to feed
High

Execution with Unnecessary Privileges in JupyterApp

Type: advisorySources: OSV

Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-39286
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 08:23 UTC · Revision 1

Source evidence

Execution with Unnecessary Privileges in JupyterApp

core-osv · Original source

Published 26 Oct 2022, 00:00 UTC

Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.

osv:CVE-2022-39286
Complete source record
{
  "id": "de821b648a776f53126a75ae3c5fa2bf4f8aeaeed8626057a0d0eaa490d6da2e",
  "url": "https://osv.dev/vulnerability/CVE-2022-39286",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Execution with Unnecessary Privileges in JupyterApp",
    "summary": "Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.",
    "evidence": "osv:CVE-2022-39286",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2022-39286",
      "aliases": [
        "CVE-2022-39286",
        "GHSA-m678-f26j-3hrp",
        "PYSEC-2022-42974"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/jupyter/jupyter_core",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "a8eac8cb0403e148880f1ae9e71dbb5db6451efe"
                },
                {
                  "fixed": "1118c8ce01800cb689d51f655f5ccef19516e283"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:jupyter:jupyter_core:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.11.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "1118c8ce01800cb689d51f655f5ccef19516e283"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "4.11.1",
            "4.11.0",
            "4.10.0",
            "4.9.2",
            "4.9.1",
            "4.9.1rc0",
            "4.9.0",
            "4.9.0rc0",
            "4.8.0",
            "4.7.1",
            "4.7.0",
            "4.7.0rc0",
            "4.6.3",
            "4.6.2",
            "4.6.1",
            "4.6.0",
            "4.5.0",
            "4.4.0",
            "4.3.0",
            "4.2.1",
            "4.2.0",
            "4.1.1",
            "4.1.0",
            "4.0.6",
            "4.0.5",
            "4.0.4",
            "4.0.3",
            "4.0.2",
            "4.0.1",
            "4.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39286.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:27.144071006Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39286.json",
        "https://github.com/jupyter/jupyter_core/security/advisories/GHSA-m678-f26j-3hrp",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KKMP5OXXIX2QAUNVNJZ5UEQFKDYYJVBA/",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YIDN7JMLK6AOMBQI4QPSW4MBQGWQ5NIN/",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-39286",
        "https://security.gentoo.org/glsa/202301-04",
        "https://www.debian.org/security/2023/dsa-5422",
        "https://github.com/jupyter/jupyter_core/commit/1118c8ce01800cb689d51f655f5ccef19516e283",
        "https://lists.debian.org/debian-lts-announce/2022/11/msg00022.html"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-250",
          "CWE-269"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39286.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-39286",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 493717,
  "published_at": "2022-10-26T00:00:00+00:00"
}