Skip to content
Heist/ feed
Back to feed
UnratedFix available

CVE-2017-7660: Security Vulnerability in secure inter-node communication in Apache Solr

Type: patchSources: Apache Solr security

A crafted node name could allow a malicious node to be treated as a cluster member. The announcement recommends upgrading Solr 6.x to 6.6.0 or higher; 5.x users should apply the referenced patch. Exposure depends on authentication configuration.

Products
Solr
Affected versions
Solr 5.3 to 5.5.4, Solr 6.0 to 6.5.1
Fixed versions
6.6.0 or higher
CVEs
CVE-2017-7660
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 22:38 UTC · Revision 1

Source evidence

CVE-2017-7660: Security Vulnerability in secure inter-node communication in Apache Solr

official-apache-solr-security · Original source

Published 7 Jul 2017, 00:00 UTC

A crafted node name could allow a malicious node to be treated as a cluster member. The announcement recommends upgrading Solr 6.x to 6.6.0 or higher; 5.x users should apply the referenced patch. Exposure depends on authentication configuration.

It is possible to create a specially crafted node name that does not exist as part of the cluster and point it to a malicious node. This can trick the nodes in cluster to believe that the malicious node is a member of the cluster.

Solr

Fixed versions: 6.6.0 or higher

Prerequisites: if Solr users have enabled BasicAuth authentication mechanism using the BasicAuthPlugin; if the user has implemented a custom Authentication plugin, which does not implement either "HttpClientInterceptorPlugin" or "HttpClientBuilderPlugin"; Users who only use SSL without basic authentication or those who use Kerberos are not affected.

Complete source record
{
  "id": "a7bfa5f0a0d9208bb24b2e7e989bcfb80eae6445772b0e890742957631b323cb",
  "url": "https://solr.apache.org/cve-2017-7660-security-vulnerability-in-secure-inter-node-communication-in-apache-solr.html",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "CVE-2017-7660: Security Vulnerability in secure inter-node communication in Apache Solr",
    "summary": "A crafted node name could allow a malicious node to be treated as a cluster member. The announcement recommends upgrading Solr 6.x to 6.6.0 or higher; 5.x users should apply the referenced patch. Exposure depends on authentication configuration.",
    "evidence": "It is possible to create a specially crafted node name that does not exist as part of the cluster and point it to a malicious node. This can trick the nodes in cluster to believe that the malicious node is a member of the cluster.",
    "products": [
      {
        "name": {
          "value": "Solr",
          "evidence": "Versions Affected: Solr 5.3 to 5.5.4"
        },
        "prerequisites": [
          {
            "value": "if Solr users have enabled BasicAuth authentication mechanism using the BasicAuthPlugin",
            "evidence": "if Solr users have enabled BasicAuth authentication mechanism using the BasicAuthPlugin"
          },
          {
            "value": "if the user has implemented a custom Authentication plugin, which does not implement either \"HttpClientInterceptorPlugin\" or \"HttpClientBuilderPlugin\"",
            "evidence": "if the user has implemented a custom Authentication plugin, which does not implement either \"HttpClientInterceptorPlugin\" or \"HttpClientBuilderPlugin\""
          },
          {
            "value": "Users who only use SSL without basic authentication or those who use Kerberos are not affected.",
            "evidence": "Users who only use SSL without basic authentication or those who use Kerberos are not affected."
          }
        ],
        "fixed_versions": [
          {
            "value": "6.6.0 or higher",
            "evidence": "6.x users should upgrade to 6.6.0 or higher"
          }
        ],
        "affected_versions": [
          {
            "value": "Solr 5.3 to 5.5.4",
            "evidence": "Versions Affected: Solr 5.3 to 5.5.4"
          },
          {
            "value": "Solr 6.0 to 6.5.1",
            "evidence": "Solr 6.0 to 6.5.1"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2017-7660",
        "evidence": "CVE-2017-7660: Security Vulnerability in secure inter-node communication in Apache Solr"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-apache-solr-security",
  "document_id": 23003,
  "published_at": "2017-07-07T00:00:00+00:00"
}