UnratedFix available
nodejs — security advisory
The Update method in src/node_http_parser.cc in Node.js before 0.6.17 and 0.7 before 0.7.8 does not properly check the length of a string, which allows remote attackers to obtain sensitive information (request header contents) and possibly spoof HTTP headers via a zero length string.
- Products
- nodejs
- Affected versions
- Not specified
- Fixed versions
- 0.6.17~dfsg1-1
- CVEs
- CVE-2012-2330
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 23:46 UTC · Revision 1
Source evidence
The Update method in src/node_http_parser.cc in Node.js before 0.6.17 and 0.7 before 0.7.8 does not properly check the length of a string, which allows remote attackers to obtain sensitive information (request header contents) and possibly spoof HTTP headers via a zero length string.
osv:DEBIAN-CVE-2012-2330
nodejs
Fixed versions: 0.6.17~dfsg1-1
nodejs
Fixed versions: 0.6.17~dfsg1-1
nodejs
Fixed versions: 0.6.17~dfsg1-1
Complete source record
{
"id": "8327e0c276301e249881663a045abe422e566cd18fc30a10de3b18e1aaf04c6b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2012-2330",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2012-2330",
"summary": "The Update method in src/node_http_parser.cc in Node.js before 0.6.17 and 0.7 before 0.7.8 does not properly check the length of a string, which allows remote attackers to obtain sensitive information (request header contents) and possibly spoof HTTP headers via a zero length string.",
"evidence": "osv:DEBIAN-CVE-2012-2330",
"products": [
{
"name": {
"value": "nodejs",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.6.17~dfsg1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "nodejs",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.6.17~dfsg1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "nodejs",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.6.17~dfsg1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2012-2330",
"aliases": [
"DEBIAN-CVE-2012-2330"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.6.17~dfsg1-1"
}
]
}
],
"package": {
"name": "nodejs",
"purl": "pkg:deb/debian/nodejs?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-2330.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.6.17~dfsg1-1"
}
]
}
],
"package": {
"name": "nodejs",
"purl": "pkg:deb/debian/nodejs?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-2330.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.6.17~dfsg1-1"
}
]
}
],
"package": {
"name": "nodejs",
"purl": "pkg:deb/debian/nodejs?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2012-2330.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T17:47:51.183229474Z",
"provider": "osv",
"upstream": [
"CVE-2012-2330"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2012-2330"
]
},
"related_cves": [
{
"value": "CVE-2012-2330",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 419294,
"published_at": "2012-08-13T23:55:01.13+00:00"
}