Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-1000403

Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 1.20 and later.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-1000403
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 06:32 UTC · Revision 1

Source evidence

CVE-2018-1000403

core-osv · Original source

Published 9 Jul 2018, 13:29 UTC

Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 1.20 and later.

osv:CVE-2018-1000403
Complete source record
{
  "id": "d97c7b33e94d86b27b9ee2d34fc3a7abd14ce3c6a990b9314d265d8c4242c583",
  "url": "https://osv.dev/vulnerability/CVE-2018-1000403",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-1000403",
    "summary": "Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 1.20 and later.",
    "evidence": "osv:CVE-2018-1000403",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2018-1000403",
      "aliases": [
        "CVE-2018-1000403",
        "GHSA-h66p-m766-33fv"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/jenkinsci/aws-codedeploy-plugin",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "1d92eac8dea8efd4a271c0dd6ff59b0ef1d4dc9e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:jenkins:aws_codedeploy:*:*:*:*:*:jenkins:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "1.19"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "codedeploy-1.19",
            "codedeploy-1.18",
            "codedeploy-1.17",
            "codedeploy-1.15",
            "codedeploy-1.14",
            "codedeploy-1.13",
            "codedeploy-1.12",
            "codedeploy-1.5",
            "codedeploy-1.4"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-1000403.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:40.965639237Z",
      "provider": "osv",
      "references": [
        "https://jenkins.io/security/advisory/2018-06-25/#SECURITY-833"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-1000403",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 435058,
  "published_at": "2018-07-09T13:29:00.303+00:00"
}