UnratedFix available
mod-wsgi — security advisory
The mod_wsgi module before 3.5 for Apache, when daemon mode is enabled, does not properly handle error codes returned by setuid when run on certain Linux kernels, which allows local users to gain privileges via vectors related to the number of running processes.
- Products
- mod-wsgi
- Affected versions
- Not specified
- Fixed versions
- 3.5-1
- CVEs
- CVE-2014-0240
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:45 UTC · Revision 1
Source evidence
The mod_wsgi module before 3.5 for Apache, when daemon mode is enabled, does not properly handle error codes returned by setuid when run on certain Linux kernels, which allows local users to gain privileges via vectors related to the number of running processes.
osv:DEBIAN-CVE-2014-0240
mod-wsgi
Fixed versions: 3.5-1
mod-wsgi
Fixed versions: 3.5-1
mod-wsgi
Fixed versions: 3.5-1
Complete source record
{
"id": "35cb9173a8709a49d26802398306533d0b25eef370579a2223369091143bddb0",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-0240",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-0240",
"summary": "The mod_wsgi module before 3.5 for Apache, when daemon mode is enabled, does not properly handle error codes returned by setuid when run on certain Linux kernels, which allows local users to gain privileges via vectors related to the number of running processes.",
"evidence": "osv:DEBIAN-CVE-2014-0240",
"products": [
{
"name": {
"value": "mod-wsgi",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.5-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mod-wsgi",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.5-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mod-wsgi",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.5-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-0240",
"aliases": [
"DEBIAN-CVE-2014-0240"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.5-1"
}
]
}
],
"package": {
"name": "mod-wsgi",
"purl": "pkg:deb/debian/mod-wsgi?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0240.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.5-1"
}
]
}
],
"package": {
"name": "mod-wsgi",
"purl": "pkg:deb/debian/mod-wsgi?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0240.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.5-1"
}
]
}
],
"package": {
"name": "mod-wsgi",
"purl": "pkg:deb/debian/mod-wsgi?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-0240.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:35.869681725Z",
"provider": "osv",
"upstream": [
"CVE-2014-0240"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-0240"
]
},
"related_cves": [
{
"value": "CVE-2014-0240",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 414334,
"published_at": "2014-05-27T14:55:12.197+00:00"
}