Medium
Apache Allura: Stored authenticated XSS
Type: advisorySources: OSV
Apache Allura's neighborhood settings are vulnerable to a stored XSS attack. Only neighborhood admins can access these settings, so the scope of risk is limited to configurations where neighborhood admins are not fully trusted. This issue affects Apache Allura: from 1.4.0 through 1.17.0. Users are recommended to upgrade to version 1.17.1, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-38379
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 10:05 UTC · Revision 1
Source evidence
Apache Allura's neighborhood settings are vulnerable to a stored XSS attack. Only neighborhood admins can access these settings, so the scope of risk is limited to configurations where neighborhood admins are not fully trusted. This issue affects Apache Allura: from 1.4.0 through 1.17.0. Users are recommended to upgrade to version 1.17.1, which fixes the issue.
osv:CVE-2024-38379
Complete source record
{
"id": "c6c5839f369b234f831acc85af7dac159444e4a5f64a54d021c6ba49e960980f",
"url": "https://osv.dev/vulnerability/CVE-2024-38379",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Allura: Stored authenticated XSS",
"summary": "Apache Allura's neighborhood settings are vulnerable to a stored XSS attack. Only neighborhood admins can access these settings, so the scope of risk is limited to configurations where neighborhood admins are not fully trusted. This issue affects Apache Allura: from 1.4.0 through 1.17.0. Users are recommended to upgrade to version 1.17.1, which fixes the issue.",
"evidence": "osv:CVE-2024-38379",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-38379",
"aliases": [
"CVE-2024-38379"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/allura",
"type": "GIT",
"events": [
{
"introduced": "1ffd75eb78df895f05ae22fc9c5ed4262d04c285"
},
{
"fixed": "75e520f923c87f65026ff034e6da69d10f8d97a9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:allura:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.4.0"
},
{
"fixed": "1.17.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"rel/1.17.0",
"rel/1.16.0",
"rel/1.15.0",
"rel/1.14.0",
"rel/1.13.0",
"rel/1.12.0",
"rel/1.11.1",
"rel/1.11.0",
"rel/1.10.0",
"rel/1.9.0",
"rel/1.8.1",
"rel/1.8.0",
"rel/1.7.0",
"rel/1.6.0",
"rel/1.5.0",
"rel/1.4.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-38379.json"
}
}
],
"modified": "2026-10-28T02:30:27.556582172Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/38xxx/CVE-2024-38379.json",
"https://lists.apache.org/thread/2lb6vp00sj2b2snpmhff5lyortxjsnrp",
"https://nvd.nist.gov/vuln/detail/CVE-2024-38379"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "1.4.0"
},
{
"last_affected": "1.17.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/38xxx/CVE-2024-38379.json"
}
},
"related_cves": [
{
"value": "CVE-2024-38379",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 494384,
"published_at": "2024-06-22T09:09:32.464+00:00"
}