redis — security advisory
Redis is an in-memory database that persists on disk. Prior to versions 6.2.7 and 7.0.0, an attacker attempting to load a specially crafted Lua script can cause NULL pointer dereference which will result with a crash of the redis-server process. The problem is fixed in Redis versions 7.0.0 and 6.2.7. An additional workaround to mitigate this problem without patching the redis-server executable, if Lua scripting is not being used, is to block access to `SCRIPT LOAD` and `EVAL` commands using ACL rules.
- Products
- redis
- Affected versions
- Not specified
- Fixed versions
- 5:7.0.1-4
- CVEs
- CVE-2022-24736
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:43 UTC · Revision 1
Source evidence
Redis is an in-memory database that persists on disk. Prior to versions 6.2.7 and 7.0.0, an attacker attempting to load a specially crafted Lua script can cause NULL pointer dereference which will result with a crash of the redis-server process. The problem is fixed in Redis versions 7.0.0 and 6.2.7. An additional workaround to mitigate this problem without patching the redis-server executable, if Lua scripting is not being used, is to block access to `SCRIPT LOAD` and `EVAL` commands using ACL rules.
osv:DEBIAN-CVE-2022-24736
redis
Fixed versions: 5:7.0.1-4
redis
Fixed versions: 5:7.0.1-4
redis
Fixed versions: 5:7.0.1-4
Complete source record
{
"id": "b25acaad65f5e38aae9c5daa8b54caca5c3ef55fabc9597886adc82da10b05a2",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-24736",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-24736",
"summary": "Redis is an in-memory database that persists on disk. Prior to versions 6.2.7 and 7.0.0, an attacker attempting to load a specially crafted Lua script can cause NULL pointer dereference which will result with a crash of the redis-server process. The problem is fixed in Redis versions 7.0.0 and 6.2.7. An additional workaround to mitigate this problem without patching the redis-server executable, if Lua scripting is not being used, is to block access to `SCRIPT LOAD` and `EVAL` commands using ACL rules.",
"evidence": "osv:DEBIAN-CVE-2022-24736",
"products": [
{
"name": {
"value": "redis",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5:7.0.1-4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "redis",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5:7.0.1-4",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "redis",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5:7.0.1-4",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-24736",
"aliases": [
"DEBIAN-CVE-2022-24736"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5:7.0.1-4"
}
]
}
],
"package": {
"name": "redis",
"purl": "pkg:deb/debian/redis?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24736.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5:7.0.1-4"
}
]
}
],
"package": {
"name": "redis",
"purl": "pkg:deb/debian/redis?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24736.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5:7.0.1-4"
}
]
}
],
"package": {
"name": "redis",
"purl": "pkg:deb/debian/redis?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-24736.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:01:44.544415011Z",
"provider": "osv",
"upstream": [
"CVE-2022-24736"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-24736"
]
},
"related_cves": [
{
"value": "CVE-2022-24736",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323122,
"published_at": "2022-04-27T20:15:09.857+00:00"
}