Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2018-18035

A vulnerability in flashcanvas.swf in OpenEMR before 5.0.1 Patch 6 could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack on a targeted system.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2018-18035
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 07:32 UTC · Revision 1

Source evidence

CVE-2018-18035

core-osv · Original source

Published 2 Apr 2019, 22:29 UTC

A vulnerability in flashcanvas.swf in OpenEMR before 5.0.1 Patch 6 could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack on a targeted system.

osv:CVE-2018-18035
Complete source record
{
  "id": "c670e108c3ef19c7f083b05bbf199c32a558259c1b7175f6a0461d368093f7bb",
  "url": "https://osv.dev/vulnerability/CVE-2018-18035",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2018-18035",
    "summary": "A vulnerability in flashcanvas.swf in OpenEMR before 5.0.1 Patch 6 could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack on a targeted system.",
    "evidence": "osv:CVE-2018-18035",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2018-18035",
      "aliases": [
        "CVE-2018-18035"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/openemr/openemr",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "771dd69c5a7d9e2eb382ec99ca5fa99a86ffe62b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:open-emr:openemr:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "5.0.1.6"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v5_0_1_5",
            "v5_0_1_4",
            "v5_0_1_3",
            "v5_0_1_2",
            "v5_0_1_1",
            "v5_0_1",
            "v3_0_1",
            "v3_0_0",
            "v2_9_0",
            "v2_8_3",
            "v2_8_2",
            "v2_8_1",
            "v2_8_0",
            "v2_7_3-rc1",
            "v2_7_2",
            "v2_7_2-rc2",
            "v2_7_2-rc1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-18035.json"
          }
        }
      ],
      "modified": "2026-10-24T10:30:54.634887362Z",
      "provider": "osv",
      "references": [
        "https://www.open-emr.org/wiki/index.php/OpenEMR_Patches",
        "https://www.purplemet.com/blog/openemr-xss-vulnerability"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2018-18035",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 438239,
  "published_at": "2019-04-02T22:29:00.237+00:00"
}