vm2 before 3.11.7 Module Allowlist Bypass via Custom Resolver
vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-92951
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 07:58 UTC · Revision 1
Source evidence
vm2 before 3.11.7 Module Allowlist Bypass via Custom Resolver
core-osv · Original sourcePublished 17 Sept 2026, 13:46 UTC
vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.
osv:CVE-2026-92951
Complete source record
{
"id": "fcc68aa2f37d86f50e40d0750d44dbfc714096b168f71f7c8902838d59b5fa8b",
"url": "https://osv.dev/vulnerability/CVE-2026-92951",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "vm2 before 3.11.7 Module Allowlist Bypass via Custom Resolver",
"summary": "vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.",
"evidence": "osv:CVE-2026-92951",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-92951",
"aliases": [
"CVE-2026-92951",
"GHSA-c48m-32m9-vx93"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/patriksimek/vm2",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "0c5b63a228c0af88d4a0d364ab0b90df278d710e"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "3.11.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "2"
},
{
"fixed": "3.11.7"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"3.11.6",
"v3.11.5",
"v3.11.4",
"v3.11.3",
"v3.11.2",
"v3.11.1",
"v3.11.0",
"v3.10.5",
"v3.10.4",
"v3.10.3",
"v3.10.2",
"v3.10.1",
"v3.10.0",
"3.9.19",
"3.9.18",
"3.9.17",
"3.9.16",
"3.9.15",
"3.9.14",
"3.9.13",
"3.9.12",
"3.9.11",
"3.9.10",
"3.9.9",
"3.9.8",
"3.9.7",
"3.9.6",
"3.9.5",
"3.9.4",
"3.9.3",
"v3.9.2",
"v3.9.1",
"v3.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-92951.json"
}
}
],
"modified": "2026-10-28T02:30:33.881543135Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/92xxx/CVE-2026-92951.json",
"https://github.com/patriksimek/vm2/security/advisories/GHSA-c48m-32m9-vx93",
"https://nvd.nist.gov/vuln/detail/CVE-2026-92951",
"https://www.vulncheck.com/advisories/vm2-before-3.11.7-module-allowlist-bypass-via-custom-resolver"
],
"provider_metadata": {
"cwe_ids": [
"CWE-706"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/92xxx/CVE-2026-92951.json"
}
},
"related_cves": [
{
"value": "CVE-2026-92951",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 501015,
"published_at": "2026-09-17T13:46:10.792+00:00"
}