Skip to content
Heist/ feed
Back to feed
Low

LibreNMS has Weak Password Policy

Type: advisorySources: OSV

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a weak password policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks. This issue has been patched in version 25.11.0.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-65014
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 03:37 UTC · Revision 1

Source evidence

LibreNMS has Weak Password Policy

core-osv · Original source

Published 18 Nov 2025, 23:01 UTC

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a weak password policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks. This issue has been patched in version 25.11.0.

osv:CVE-2025-65014
Complete source record
{
  "id": "8bb41ce67edf6808d5b2b5caf4c96abf9e75c7e9ed0ceb414b2307ddb5d6d49e",
  "url": "https://osv.dev/vulnerability/CVE-2025-65014",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "LibreNMS has Weak Password Policy",
    "summary": "LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.11.0, a weak password policy vulnerability was identified in the user management functionality of the LibreNMS application. This vulnerability allows administrators to create accounts with extremely weak and predictable passwords, such as 12345678. This exposes the platform to brute-force and credential stuffing attacks. This issue has been patched in version 25.11.0.",
    "evidence": "osv:CVE-2025-65014",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2025-65014",
      "aliases": [
        "CVE-2025-65014",
        "GHSA-5mrf-j8v6-f45g"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/librenms/librenms",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "aa2146888bee34ae7b250f14992a2f195ffa0c53"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "25.11.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:librenms:librenms:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "25.11.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "25.10.0",
            "25.9.0",
            "25.8.0",
            "25.7.0",
            "25.6.0",
            "25.5.0",
            "25.4.0",
            "25.3.0",
            "25.2.0",
            "25.1.0",
            "24.12.0",
            "24.11.0",
            "24.10.1",
            "24.10.0",
            "24.9.1",
            "24.9.0",
            "24.8.0",
            "24.7.0",
            "24.6.0",
            "24.5.0",
            "24.4.1",
            "24.4.0",
            "24.3.0",
            "24.2.0",
            "24.1.0",
            "23.11.0",
            "23.10.0",
            "23.9.1",
            "23.9.0",
            "23.8.2",
            "23.8.1",
            "23.8.0",
            "23.7.0",
            "23.6.0",
            "23.5.0",
            "23.4.1",
            "23.4.0",
            "23.2.0",
            "23.1.0",
            "22.12.0",
            "22.11.0",
            "22.10.0",
            "22.9.0",
            "22.8.0",
            "22.7.0",
            "22.6.0",
            "22.5.0",
            "22.4.0",
            "22.3.0",
            "22.2.1",
            "22.2.0",
            "22.1.0",
            "21.12.1",
            "21.12.0",
            "21.11.0",
            "21.10.0",
            "21.9.0",
            "21.8.0",
            "21.7.0",
            "21.6.0",
            "21.5.1",
            "21.5.0",
            "21.4.0",
            "21.3.0",
            "21.2.0",
            "21.1.0",
            "1.70.1",
            "1.70.0",
            "1.69",
            "1.68",
            "1.67",
            "1.66",
            "1.65",
            "1.64.1",
            "1.64",
            "1.63",
            "1.62",
            "1.61",
            "1.60",
            "1.59",
            "1.58.1",
            "1.58",
            "1.57",
            "1.56",
            "1.55",
            "1.54",
            "1.53.1",
            "1.53",
            "1.52",
            "1.51",
            "1.50",
            "1.49",
            "1.48.1",
            "1.48",
            "1.47",
            "1.46",
            "1.45",
            "1.44",
            "1.43",
            "1.42.01",
            "1.42",
            "1.41",
            "1.40",
            "1.39",
            "1.38",
            "1.37",
            "1.36",
            "1.35",
            "1.33",
            "1.32",
            "1.31.03",
            "1.31.02",
            "1.31.01",
            "1.28",
            "1.27",
            "1.26",
            "1.25",
            "1.21",
            "201609",
            "1.20",
            "20160828",
            "1.19",
            "201608",
            "201607",
            "201606",
            "201605",
            "201604",
            "201603",
            "201602",
            "201601",
            "201512",
            "201511",
            "201510",
            "201509",
            "201508",
            "201507",
            "201505",
            "201506",
            "0.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-65014.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:32.726537849Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65014.json",
        "https://github.com/librenms/librenms/security/advisories/GHSA-5mrf-j8v6-f45g",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-65014"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-521"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65014.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-65014",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 500065,
  "published_at": "2025-11-18T23:01:40.005+00:00"
}