Security advisory
A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/add_field_to_form.php. The manipulation of the argument field_name/merge_tag/field_type/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 is able to address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-4244
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:58 UTC · Revision 1
Source evidence
A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/add_field_to_form.php. The manipulation of the argument field_name/merge_tag/field_type/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 is able to address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.
osv:CVE-2021-4244
Complete source record
{
"id": "3d3c65233c8207685091adbb262527cf05b1e7a341a7746f3b86115cc844847d",
"url": "https://osv.dev/vulnerability/CVE-2021-4244",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-4244",
"summary": "A vulnerability classified as problematic has been found in yikes-inc-easy-mailchimp-extender Plugin up to 6.8.5. This affects an unknown part of the file admin/partials/ajax/add_field_to_form.php. The manipulation of the argument field_name/merge_tag/field_type/list_id leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 6.8.6 is able to address this issue. The name of the patch is 3662c6593aa1bb4286781214891d26de2e947695. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-215307.",
"evidence": "osv:CVE-2021-4244",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-4244",
"aliases": [
"CVE-2021-4244",
"GHSA-837v-6vgx-jqcc"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/evanherman/yikes-inc-easy-mailchimp-extender",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "3662c6593aa1bb4286781214891d26de2e947695"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:yikesplugins:easy_forms_for_mailchimp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.8.6"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "3662c6593aa1bb4286781214891d26de2e947695"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "3662c6593aa1bb4286781214891d26de2e947695"
}
],
"source": "REFERENCES_TAG",
"original_tag": "6.8.6"
}
]
}
}
],
"versions": [
"6.8.5",
"6.8.4",
"6.8.3",
"6.8.2",
"6.8.1",
"6.8.0",
"v6.7.0",
"6.7.0",
"6.6.4",
"6.6.2",
"6.6.1",
"6.6.0",
"v.6.2.3",
"v.6.2.2",
"v6.2.1",
"v6.2.0",
"v6.0.1",
"6.0.0-rc1.0",
"4.2.1",
"4.2",
"4.1",
"v4.0",
"4.0",
"3.0.1",
"3.0",
"2.2.0",
"2.1.1",
"2.1.0",
"2.0.3",
"2.0.2",
"2.0.1",
"2.0.0",
"1.3.1",
"1.3.0",
"1.2.0",
"1.1.0",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-4244.json"
}
}
],
"modified": "2026-10-20T10:55:00.576150487Z",
"provider": "osv",
"references": [
"https://github.com/EvanHerman/yikes-inc-easy-mailchimp-extender/releases/tag/6.8.6",
"https://vuldb.com/?id.215307",
"https://github.com/EvanHerman/yikes-inc-easy-mailchimp-extender/commit/3662c6593aa1bb4286781214891d26de2e947695",
"https://github.com/EvanHerman/yikes-inc-easy-mailchimp-extender/pull/889"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-4244",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 386666,
"published_at": "2022-12-12T14:15:10.4+00:00"
}