High
Security advisory
PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-19296
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:42 UTC · Revision 1
Source evidence
PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.
osv:CVE-2018-19296
Complete source record
{
"id": "6fab03057b6db68eed211ae7a8f74b1d7a99b33d43ed24879334855c0cafda9f",
"url": "https://osv.dev/vulnerability/CVE-2018-19296",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-19296",
"summary": "PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.",
"evidence": "osv:CVE-2018-19296",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-19296",
"aliases": [
"CVE-2018-19296",
"GHSA-7w4p-72j7-v7c2"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpmailer/phpmailer",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "dde1db116511aa4956389d75546c5be4c2beb2a6"
},
{
"introduced": "ea25dc122d22966b7dd4ca1083c63afeeb50dfcd"
},
{
"fixed": "8190d73eb5def11a43cfb020b7f36db65330698c"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.2.27"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.0.6"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "dde1db116511aa4956389d75546c5be4c2beb2a6"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v5.2.27"
},
{
"range": [
{
"fixed": "8190d73eb5def11a43cfb020b7f36db65330698c"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v6.0.6"
}
]
}
}
],
"versions": [
"v6.0.5",
"v6.0.4",
"v6.0.3",
"v6.0.2",
"v5.2.26",
"v6.0.1",
"v6.0.0",
"v5.2.25",
"v5.2.24",
"v5.2.23",
"v5.2.22",
"v5.2.21",
"v5.2.20",
"v5.2.19",
"v5.2.18",
"v5.2.17",
"v5.2.16",
"v5.2.15",
"v5.2.14",
"v5.2.13",
"v5.2.10",
"v5.2.9",
"v5.2.8",
"v5.2.7",
"v5.2.6",
"v5.2.5",
"v5.2.4",
"v5.2.2",
"v5.2.1",
"v5.2.0",
"v2.2.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-19296.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress",
"type": "GIT",
"events": [
{
"introduced": "3921fd373acaeeeee2029f762b676075cf375b33"
},
{
"last_affected": "058f9903676a7efaee534a682df0a2a8b87574d8"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.7"
},
{
"last_affected": "5.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-19296.json"
}
},
{
"ranges": [
{
"repo": "https://github.com/wordpress/wordpress-develop",
"type": "GIT",
"events": [
{
"introduced": "f1d358137f7ed657db6afec1b1eca0b9f7814e25"
},
{
"last_affected": "895d6a691d7ccdfe80cdf999bc0c8a78d11ad55a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.7"
},
{
"last_affected": "5.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-19296.json"
}
}
],
"modified": "2026-10-24T10:49:38.622605137Z",
"provider": "osv",
"references": [
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3B5WDPGUFNPG4NAZ6G4BZX43BKLAVA5B/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KPU66INRFY5BQ3ESVPRUXJR4DXQAFJVT/",
"https://github.com/PHPMailer/PHPMailer/releases/tag/v5.2.27",
"https://github.com/PHPMailer/PHPMailer/releases/tag/v6.0.6",
"https://lists.debian.org/debian-lts-announce/2018/12/msg00020.html",
"https://www.debian.org/security/2018/dsa-4351"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
}
],
"source": "CPE_STRING"
}
]
},
{
"cpes": [
"cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*",
"cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*"
],
"vendor_product": "fedoraproject:fedora",
"extracted_events": [
{
"range": [
{
"introduced": "33"
},
{
"last_affected": "33"
},
{
"introduced": "34"
},
{
"last_affected": "34"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2018-19296",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 441785,
"published_at": "2018-11-16T09:29:00.23+00:00"
}